Pcgi and Coppermine

software development

#1

I’m wanting to install the Coppermine photo gallery (http://coppermine.sourceforge.net/) script (written in PHP) on my site. In another thread, someone mentioned that this is quick and simple, so long as I’m running PHP-CGI (I am) and then there’s a simple change I have to make to my .htaccess file so that Coppermine can create new files.

My question: What is the simple change I need to make to my .htaccess file?

Thanks for sharing your knowledge!


#2

You don’t have to make any changes to .htaccess to get coppermine working. The install process with prompt you if anything else need doing (i.e chmoding a directory to 777).

Good luck
Mike


#3

AddType php-cgi .php

is the line that you will need to add to your htacess file to run the php as cgi. Most (all that I know of) image galleries will require that to function on Dreamhost.

[color=#0000CC]jason[/color]


#4

Thanks, Jason-- thats what I was looking for. I’m setting everything up now, with fingers crossed!


#5

If you’re alrealdy running php as cgi (Run PHP as CGI? option selected on the domain settings) then there’s no need to add the AddType line in your .htaccess file.


#6

Yes, I am running PHP as CGI.

The script installed correctly, but I receive an error when I try to view individual albums-- the script returns: The selected album/picture does not exist !
But the albums do exist (or at least my admin mode tells me they do)

I posted over at Coppermine’s own troubleshooting forum, to see if they have any ideas. The documentation says that Coppermine has no trouble running in safe mode, even with the ‘open basedir restriction’ active.

Perhaps I should try removing the AddType line from my .htaccess file?


#7

Or perhaps I should try keeping the AddType line and de-activating “run PHP as CGI”?


#8

I’ve got coppermine running at www.photoserver.co.uk . I’ve got the Run PHP as CGI option selected and the following .htaccess file…

<Files .htaccess>
order allow,deny
deny from all

Options -indexes

ErrorDocument 404 /error/404.html
ErrorDocument 403 /error/403.html

SetEnvIfNoCase Referer “.(adultsite|adultforum).” BadReferrer
order deny,allow
deny from env=BadReferrer

Which version of coppermine are you running?


#9

I’m running the most recent stable release, v1.2.

I removed the AddType line from my .htaccess file, and the script runs just as well-- or shall I say, just the way it did before I removed the AddType line.

So now I have “run php as cgi” active, and my .htaccess file does not have the AddType line, and my albums are still returning a “non-existent” error.

Over at the coppermine forums, they suggested I try initiating Coppermine’s “Silly Safe Mode”. I’m off to try that now…


#10

Coppermine is at version 1.2.1 . I’d suggest starting from scratch…


#11

Oops, I meant 1.2.1 – I downloaded it two nights ago.


#12

Problem solved!!!

The problem I was experiencing disappeared as soon as I uploaded an image to the album. In other words, a blank album returns an error, but an album with at least one picture in it works fine.

Thanks for your help, guys. If anyone else runs into this problem, try uploading an image to the album.