Passwordless ssh not working


#1

Hello,

I followed the wiki passwordless ssh directions (http://wiki.dreamhost.com/index.php/SSH#Passwordless_Login) exactly (twice) but keep getting the following error message:

mac-mini:/ john$ ssh jcatalano@www.webagogue.com
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: UNPROTECTED PRIVATE KEY FILE! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Permissions 0777 for ‘/Volumes/MSTACK/Users/john/.ssh/id_rsa’ are too open.
It is recommended that your private key files are NOT accessible by others.
This private key will be ignored.
bad permissions: ignore key: /Volumes/MSTACK/Users/john/.ssh/id_rsa
Enter passphrase for key ‘/Volumes/MSTACK/Users/john/.ssh/id_rsa’:

Any tips?


#2

Looks like you didn’t do the permissions steps at the wiki page:

chmod 700 ~/.ssh
chmod 600 ~/.ssh/authorized_keys

tor.eff.org


#3

No, I specifically did those steps both times I tried. I followed the wiki exactly.


#4

I’m going by:

[quote]Permissions 0777 for ‘/Volumes/MSTACK/Users/john/.ssh/id_rsa’ are too open

[/quote]

777 is obviously not 700 or 600.

What does ls -la show for permissions for .ssh and below?

tor.eff.org


#5

On my local machine I did:

mac-mini:~ john$ chmod go-w ~
mac-mini:~ john$ chmod 700 ~/.ssh
mac-mini:~ john$ chmod 600 ~/.ssh/authorized_keys
chmod: /Volumes/MSTACK/Users/john/.ssh/authorized_keys: No such file or directory
##of course this failed because I know I don’t have this directory locally, and the tutorial doesn’t claim that I need it, but just in case.##
mac-mini:~ john$ ls -la
total 320
drwxrwxrwx 1 john john 32768 Nov 13 10:57 .
drwxrwxrwx 1 john john 32768 Nov 13 13:41 …
-rwxrwxrwx 1 john john 1675 Nov 13 11:08 id_rsa
-rwxrwxrwx 1 john john 395 Nov 13 11:08 id_rsa.pub
-rwxrwxrwx 1 john john 465 Oct 28 09:10 known_hosts
mac-mini:~/.ssh john$

And now on my dreamhost acct:
[fundip]$ cd .ssh
[fundip]$ ls
authorized_keys
[fundip]$ ls -la
total 12
drwx------ 2 jcatalano pg594577 4096 2006-11-12 18:10 .
drwxr-x–x 19 jcatalano pg594577 4096 2006-11-14 04:27 …
-rw------- 1 jcatalano pg594577 395 2006-11-12 18:09 authorized_keys
[fundip]$


#6

[quote]-rwxrwxrwx 1 john john 1675 Nov 13 11:08 id_rsa

[/quote]

I would try

chmod 600 id_rsa

on your Mac.

Probably also something like

chmod 644 id_rsa.pub known_hosts

tor.eff.org


#7

This must be some kind of Mac issue because my permissions for the local files are not changing no matter what I do. I’ll try to get this issue solved somewhere else. Thanks.


#8

I didn’t think about this before, but my home directory, which contains the .ssh folder, is on a FAT32 partition of an external drive. Am I correct that chmod doesn’t work on FAT32? And if that is the case, is there a work-around?