Password Errors on Personal Mail Domains, but not DH Domains


#1

Is there any reason why mail.[mydomain].com would throw fits about correct username and password not matching, while simply changing the server (not SSL, not ports… just servername) works perfectly?

Experienced this issue on iPhone (clean install of iOS 4.2.1).


More details:

I had IMAP working on the DH servers using mail.basseq.com (my domain), but was having issues with items marked as read via webmail or external client being marked as such on the iPhone.

I deleted the account, as well as all associated outgoing servers. (iPhone has a habit of keeping a collection of outgoing servers even when you delete the main account.) When I re-added the account using the same settings (verified settings: this wasn’t just me mis-typing my password), it threw a “username/password not valid” error message.

I deleted the account, re-added the account, deleted other accounts, wiped all outgoing mail servers, validated SSL and non-encrypted port numbers and variants: nothing worked.

However, simply changing the mail server to mail.dreamhost.com solved everything. No username/password errors. With the added bonus of correctly-synching mail and no SSL cert errors.

Everything is working now, but I’d rather it be working though my domain simply for portability.[hr]
Note: I did try homie.mail.dreamhost.com, which threw the same error. Assuming this is the “proper” mail server, I wonder if this whole mess was caused by some craziness with that server.