Passenger WSGI Problems

software development

#1

I’m having problems getting even a trivial Passenger WSGI example working. I’ve enabled Passenger on the domain, and it definitely does something (if I remove passenger_wsgi.py, it just serves the deafault quickstart.html in the public dir), but if I have anything in passenger_wsgi, I get an internal server error. The odd thing is that before exporting a WSGI application (just using the example on the wiki currently), I’ve tried simply writing to a file (which works if I just execute the script from the shell), but no file is ever written out, so it’s as if Passenger is dying before it executes any of passenger_wsgi. There are no errors in my logs. Any thoughts? Should writing to a file in passenger_wsgi before exporting my WSGI application work?

Thanks!


#2

It’ll help if you paste your passenger_wsgi.py.


#3

Thanks for the reply! I’ve tried pretty much all of the examples from http://wiki.dreamhost.com/Passenger_WSGI - both the minimal example, the example using Paste, and the example using local logging. I was able to get Passenger working with a minimal Rails app, but the mechanism for starting that up is different enough that I doubt that matters.

I ended up just getting this working with FastCGI, but I’m not particularly happy with it, and am considering switching to WebFaction which allows for a much more trivial WSGI solution.