Panel only good with IE?


#1

Hi all, this is mostly directed to the DreamHost team, but I didn’t want to open a support case because it’s more of a general thing.

Hasn’t anybody noticed that the Panel only works in IE? I don’t know about Konqueror etc. but Mozilla lacks the left-hand navigation tools, so unless I know the “?tree=mail.aliases&” part of the URL, I can’t use Mozilla to control my account.

Maybe it’s just as well though, because there seems to be some session control that only works really well if you’re looking at the Panel with only one browser window. If you use several windows (or tabs) then the Panel gets confused and you risk editing/deleting the wrong mailbox/domain/whatever. I learned the hard way that I should never have more than one window open that shows the Panel.

Is it just me, or would other users also like the Panel to work well in non-IE browsers (I mean Mozilla but the question is generic)?


TorbenGB


#2

Works fine for me with the latest version of Mozilla (Firebird) on a Mac. Also works fine in Safari. Albeit a little slower than IE, but still functional. What browser, OS and version are you using?

And yes, don’t keep more than one window or tab open on the pannel. It does mess with your session cookies (I presume).

  • wil

#3

[quote]If you use several windows (or tabs) then the Panel gets confused and you risk editing/deleting the wrong mailbox/domain/whatever. I learned the hard way that I should never have more than one window open that shows the Panel.

[/quote]

Hey, I did the same when I was using Netscape. That’s also part of the reason I FINALLY (please note the word finally) about 3 months ago. I don’t know about DreamHost, but many people just don’t care about users who are not on IE. Just have to bow to reality.


[color=#CC0000]name[/color]slave
Domain Registration, Web Hosting & Search Engine Optimization


#4

I use WinXP and IE6 and Mozilla 1.5. With IE it works well, but Mozilla doesn’t display the leftmenu properly.

Prufrock, you missed some words. That’s why you finally … what?


TorbenGB


#5

[quote]Prufrock, you missed some words. That’s why you finally … what?

[/quote]

LOL! Sorry for leaving the most important part out:

That’s why I finally started using IE about 3 months ago.


[color=#CC0000]name[/color]slave
Domain Registration, Web Hosting & Search Engine Optimization


#6

[quote]Hasn’t anybody noticed that the Panel only works in IE?

[/quote]

I’d say we probably have more Mozilla users than IE users on staff, and we have a number of employees who run platforms for which IE isn’t available. I’m not aware of any problems with the web panel in Mozilla, and the left hand navigation tools work fine for me. I’ve been using Mozilla as my main browser for quite a while; currently using version 1.6a.

Just out of curiosity, are you faking your version string? Rants on why browser detection is bad notwithstanding, I do recall seeing some problems with the panel when I was faking my version string to IE.


#7

In the past month, I’ve managed my site through the web control panel on:
Win 2k Pro - Firebird 0.7
Win 2k Pro - Mozilla 1.4
Win 2K Pro - IE 6
Red Hat 9 - Firebird 0.7
Red Hat 9 - Mozilla 1.5
Mac OS X - Safari 1.1?
Mac OS X - Camino 0.6?
Mac OS X - Firebird 0.7.1
Mac OS 9 - IE 5.1

I’ve not run into any feature in the control panel that worked either significantly differently or better on IE.


#8

I use Firebird, and I have had absolutely no problems with the panel. Works just as good as it does in IE for me.


#9

Will, I’m not faking my browser string. But your question, as well as ardco’s Javascript comment, puts me on a trail: perhaps Mozilla’s built-in filtering cuts out the functionality of the Panel, or perhaps something with the bannerkiller-proxy I’m running (webwasher.com). I’ll look into these (and be ashamed that i didn’t think to look ther first!).

Since the Panel only works one-screen-at-a-time anyway, there’s no benefit in Mozilla after all. Pout. I like to work on several things at once to remedy the response times (which from Denmark aren’t always short).

Sorry for yelling in the Forum before I had checked my own pc settings! Lesson learned.


TorbenGB


#10

The panel works fine for me in Mozilla, though I’ve also observed the problems if you have multiple windows or tabs open in the panel at once.

I used Netscape as my main browser from 1995-2001, and Mozilla ever since, and I hope I never get turned to the Dark Side of the Force.

– Dan


#11

Snap, it actually works better when i fake my browser string as ’ - ’

interesting that

Firebird 0.7+ and WinXP

Also works fine with IE6 on WinXP

www.rawkstar.net