Pagespeed Optimization Blocking site with 503s

wordpress

#1

After the big ddos attack that hit DH last week, my site worked occasionally then was down for 2 days with a 503. FTP and phpmyadmin worked well.

Sent in unanswered tickets; ( after doing the usual things, disabling plugins, turning off Cloudflare etc. ) just now I focused on the too many connections part of a 503, and looked at the site statistics: obviously there wasn’t much traffic, but under browsers I found this at 50%:

Serf/1.1.0 mod_pagespeed/1.1.23.1-2169

To quote from my last ticket:

Never heard of it, and googling showed nothing useful, so concentrated on the pagespeed bit and looked at the site edit page and unchecked Page Speed Optimization < which is your tool.

It had worked before your big attack, so I guess that upset something and Google Page Speed started many requests that choked the site.

As a suggestion you may want to inform everyone else to turn it off if their site won’t work and maybe turn this option off for everyone until it is investigated.

Since this could be blocking many sites I think Dreamhost really should remove this option for now.


#2

You should be okay to turn it back on. I would speculate that Pagespeed was caching bad data (it too caches as it minimizes) and that’s what the problem was. Turning it off and back on wipes the cache.


#3

The 503’s weren’t caused by PageSpeed - but leave it turned off anyway.