Page not found issue with Wordpress

wordpress

#1

Hi,

I have 4 Wordpress installs hosted on my Dreamhost account.
Sometimes when I’m posting a new entry, update a plugin or do something other in my backend (the Dashboard) I get an error site displayed saying that “the site can’t be found”.

Does anybody else has similar issues?
Don’t know how to get rid of that annoying error.
It seems even leading to double-posting some entries. (I post, get an error that the post can’t be pusblished, but in fact has been published, then I hit publish once again and have doubled the entry.)


#2

I’ve not seen this. Is that error the standard one your browser gives you for a nonexistent site?

Are these brand new sites? Do you ever get that error when just browsing your site? Does this happen with all four sites? Are they all at different domains?

-Scott


#3

[quote]Is that error the standard one your browser gives you for a nonexistent site?

[/quote]

It’s the standard Wordpress page someone gets looking for a site that doesn’t exist.

[quote]Are these brand new sites?

[/quote]

Kind of…I’ve transferred them in August to Dreamhost.
Since then they are living here.

[quote]Do you ever get that error when just browsing your site?

[/quote]

Nope, never got that error by just browsing.

[quote]Does this happen with all four sites?

[/quote]

Yes, indeed it happens with all four sites.

[quote]Are they all at different domains?

[/quote]

The domains are:

Best,
Zettt


#4

Huh? Your web browser looks for a site. It has to connect to a computer and then ask for a web page at a certain site. So you’re not going to get a Wordpress error page if the site doesn’t exist because that means it couldn’t find a computer to connect to or the computer it connected to doesn’t know anything about the site much less give you a Wordpress error page.

Perhaps it would be more helpful to cut and paste the error message to avoid any confusion. Most likley your Wordpress install is generating URLs incorrectly. A malformed URL will lead to a “site does not exist” error because it is not using the correct domain and should be apparent in your browser address bar.

Customer since 2000 :cool: openvein.org


#5

Have you tried to Reload the page when you get the error?

How about posting a screenshot? A CMD-4, then Spacebar for just the browser window should do it. Then we can see the URL and the actual error.

-Scott


#6

Sorry…have had some troubles…anyway. Here’s the screenshot:
http://files.zettt.de/tmp/fc69cf84d502d9fff9c4dbda975f763f.png


#7

The picture looks like it is the custom 404 page for wordpress, this means wordpress is there but that wordpress is not finding any pages corresponding to the link.

Have you made any changes recently to things like permalink settings or moved things around?

Just read back a bit and realised its happening on 4 sites, is there anything common to all 4 such as plugins or special changes you have made?

[color=#CC0000]TECHNIXA97[/color] for full discount.
more codes


#8

Almost all plugins I’m using are the same on all 4 sites.
There are a few differences though. Like qTranslate, WP-Rating are unique to one or two sites.
All others share the same plugin set.

I haven’t changed anything recently.
Except that I moved my WP installs to Dreamhost. :wink:

Beforehand they were hosted on different other domain services. (Macbay, Podzilla for instance)


#9

I would take a look at how you’re redirecting zettt.de to point at zettt.de/wordpress/

.htaccess / config.php / Panel redirect-to-folder ?

It might be a case that the rewriting/redirection in that attribute is playing a role in the problems you’re witnessing site-wide when requesting a “complete” link as is shown in the screenshot.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#10

Yes, but that doesn’t resolve the error, does it?
When I get that error about 10 times a day, it seems to be a Dreamhost problem not a Wordpress problem.


#11

Please don’t feed the penis trolls. I almost did, too.

When you get that error, look through your log file in your user’s /logs directory and see what shows up.

-Scott


#12

I’m going to agree here. Try editing .htaccess, and setting the permalinks inside wordpress. It’s your best bet.


#13

I’ve had this same issue with WordPress and Dreamhost for several years. It’s REALLY annoying. I’ve never seen it with my other hosts. I use custom permalinks. No fix?


#14

ditto - usually breaks when updating plugins

i have 8 different wordpress installs - and it’s done it on all of them at various points… usually when you’re in the Admin section

and it just comes up with the page not found - and the theme for that blog - although i do have 2 wordpress installs on one domain, and when the one in a sub-directory goes it shows the main level…


#15

Write to support, and ask specifically that they check the “procwatch log” for the user running these sites. What you describe is almost always either corrupted permalinks (easily fixed by rebuilding them), or the DreamHost procwatch daemon killing your processes for using too much RAM on a shared server. When this happens, it often results in a 404 in confusion of how to route the rewrite request, or a 500 Internal Server Error (or both).

One clue to this you can see in your own logs is if the error logs reports “premature end of script header” around the time of this 404. With proper installations and non-corrupt code files, this is almost always caused by a procwatch “kill”, and the TS people can easily check to see if this is happening to you (as well as provide some suggestions on how to prevent it)


#16

Checked the Logs and yup - a few “premature end of script header” in there…

Cheers
One Step Closer :slight_smile:


#17

I’m not sure if this is documented in the wiki or not, but I was playing around with writing my own PHP app and found that when memory usage hits about 90MB or execution time is longer than about 20, maybe 30 seconds, your script will be killed for consuming too many resources. WP does not seem to be too efficient on memory, with even a bare-bones installation taking at least 30-40 MB to render a page. Add a bunch of plugins and that value could go up very quickly.


#18

I contacted support about this because 3 out of 5 times I try to save a post, I get a 500 or 404 error due to ‘premature end of header’.

Support said I was running too much memory .3 - .4% of total memory (48mb - 64mb). A base install of wordpress seems to take up about .2% (32mb). I don’t really have THAT many plugins installed and it seems one of the ones taking up memory is W3 total cache which is one of the recommended ways to optimize.

I’m starting to wonder if dreamhost just isn’t the right option for a wordpress website. I didn’t experience this before on previous hosts.

How much memory are other people using and how are you trying to reduce it? It’s hard to find plugins that are culprits.


#19

My basic site, which is unoptimised but receives almost no traffic, reports:

Executed Queries: 67 | Used memory: Init: 27.6 MB | Header: 31.9 MB | Footer: 32.8 MB | Page generated in: 2.871 seconds.

According to GD Press Tools:

That’s an incredible number of queries and a big chunk of memory just to load the dashboard, but I’ve only experienced that ‘premature end of headers’ a few times. I could never figure out what it was, but now it makes sense.

In contrast, another site I’m working on, which I hope will get at least a few hundred hits per day or more, uses at most 4-5 MB of memory, less than 10 queries, and finishes in about 300 ms. It’s based on the Dwoo templating engine.


#20

I had a problem similar to this whenever I created a new blog on my Wordpress multisite. Elsewhere I learned that this is only an issue for Dreamhost’s One-Click-Installs, and in order to fix it you have to correct wp-config.php… maybe it’s related to this?

Find this part in wp-config:
$server = DB_HOST;
$loginsql = DB_USER;
$passsql = DB_PASSWORD;
$base = DB_NAME;

Comment out the last line, like this:
$server = DB_HOST;
$loginsql = DB_USER;
$passsql = DB_PASSWORD;
/* $base = DB_NAME; */

I don’t know why, but it helped me.