OwnCloud on VPS .htaccess issues

vps

#1

hello & thank you in advance for your help.

i have been trying everything i could think of so far with no solution. i am trying to install OC in it’s own sub-domain on a dreamhost VPS and i keep getting the following error message in error.log:

[Wed Oct 23 12:19:59 2013] [crit] [client xxx.xxx.xxx.xxx] (13)Permission denied: /home/webadm_xxxx/www/cloud.xxx.com/owncloud/data/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

the permissions of the .htaccess file are:

-rw-r–r-- 1 webadm_xxxx pgxxxx 27 Oct 23 12:20 .htaccess

i tried various other owners: dhapache & www-data, in wich case i do not get the rror in the log file, but get all sorts of other errors in the web interface.

any help would be much appreciated.


#2

The permissions on that file look fine, but it’s possible that the permissions on one of the parent directories (e.g, the “data” folder it’s in) are preventing the web server from getting to it. Can you check what those look like?


#3

hello andrew –

thank you so much for your quick reply. here the permissions. my domanins are all in:

/home/webadm_xxxx/www

the permissions are as follows:

drwxr-xr-x 12 webadm_xxxx pgxxxxxx 4096 2013-10-20 21:26 www
drwxr-xr-x 2 webadm_xxxx pgxxxxxx 4096 2013-10-23 14:08 cloud.xxxx.com
drwxrwx— 2 webadm_xxxx pgxxxxxx 4096 2013-10-23 14:08 data

any suggestions would be greatly appreciated.


#4

The permissions you have set on the “data” folder are preventing the web server from reading it. You will need to set them to at least 751 (“drwxrwx–x”) to allow the web server to get into the folder and read the .htaccess file.


#5

hello andrew –

thank you for your advice. i just tried to set the directory called “data” to 751 or 771 and in both cases i still get the same error message. even when i set the folder & htaccess file to 777 i get still the same error. any other idea what could cause this issue?

thank you in advance.


#6

i keep trying to fix this issue with ownCloud installation as i keep getting server errors, that point towards permissions. what is very odd, is that when i change the permissions on the /data folder, it seems that own cloud changes them back to 770. so it seems to have access. also reading & writing files work.

had anybody successfully installed ownCloud on VPS without getting pesky htaccess error messages in their logs?

thanks in advance.