ownCloud on shared server




before anything, excuse me if this topic has been treated before, but i receive a kind-of-weird 0 hits on reply to my search. So there is some chance i did something wrong.

That being said, i’m trying to get ownCloud up and running on a shared server.

What i’ve got until now.

  • Server running PHP 5.3 FastCGI.
  • ownCloud 2 beta 3 installed and web interface working properly. Users can be created, files may be uploaded. Everything /seems/ to be smoothly running.
  • I’m unable to connect neither using Nautilus built-in support for webdav nor via Finder built-in support for webdav. The former gives a “time-out server not there connection broken” mixed and long error message. The latter says my user/pass is incorrect.

Any ideas?

Thanks :slight_smile:


Not to seem stupid or anything but did you actually set up webdav from the dh control panel on your domain and add users/passwords?


Hi Ryo-ohki, thanks for your reply.

Regarding your question,

I tried both things. The first was trying to access the webdav directory through the .php script provided by ownCloud (it’s supposed to keep you from managing all the webdav stuff). This attempt gave me the kind of errors I mentioned above.

I also tested the other way. In this case, trying to access the ./data directory inside owncloud gives a 403 error and no dialog box to enter user/pass. Trying to access via finder, an error message urges me to verify the IP address or contact my sysadmin :slight_smile:

Ok, i’ll keep trying different things today, and i come to something useful will put it here for it may be useful to someone in the future :slight_smile:

Ninja edit to ADD
Trying to access the php script directly through a web browser prompts my with a log-in dialog, to no success. It is not sending the auth info and so it gets back to the initial point (log-ind dialog) in a loop that ends when you get a bit bored and press CANCEL. Then, you receive an XML file:

<d:error xmlns:d=“DAV:” xmlns:s=“http://sabredav.org/ns”>
<s:message>No basic authentication headers were found</s:message>

Any ideas?


Do you ‘have’ to use webdav? I’m pretty sure you have to either not use webdav and use the web interface OR use webdav and only be able to access it that way and nothing else.


Yup, that’s the alternative. Using owncloud seemed a good idea, as it provides the ability of syncing many things while having them accesible via webinterface for eventual access (i.e. not your usual computer).

Thanks again!



I have the very same problem as described above.
Now, I’ve tried to enabe WebDAV on my data directory of the ownCloud install, but it didn’t change anything …

Anybody got any ideas how to fix this? I think ownCloud is just great, I only really want webDAV to work …

Has it got anything to do with the htaccess files?



I’ve the same problem …
It seems to be related to something like this http://code.google.com/p/sabredav/issues/detail?id=25#c0

so pbm with dreamhost implementation… if someone find a solution …


I’ve found a solution … change your htaccess to include :

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]


Sorry to hijack this thread, but it’s the only one I could find re: ownCloud.

I’m attempting to install ownCloud on my DH shared server, and I’m running into this error after uploading the files to my site:

PHP module zip not installed.
Please ask your server administrator to install the module.

Any idea how to fix this?


And I hate to hijack an already hijacked thread, but how can I change the max upload limit? Every time I try to change it using php.ini, I then update the .htaccess file with:
Options +ExecCGI
AddHandler php5-cgi .php
Action php-cgi /cgi-bin/php-wrapper.fcgi
Action php5-cgi /cgi-bin/php-wrapper.fcgi

This is per the DH wiki at: http://wiki.dreamhost.com/Php.ini#Custom_php.ini_across_Multiple_domains

Alas, no joy. I get an error from OwnCloud. Any thoughts?



I’m just guessing here, but /cgi-bin/php-wrapper.fcgi is not pointing to your custom wrapper which you set up in ~/cgi-bin/

You’ll either need to either add a tilde (~) or specify the whole path (/home/USERNAME/cgi-bin/php-wrapper.fcgi)


I switched my PHP to version 5.3 and ownCloud started working.


It’s a shame i just discovered your reply!

This solved the issue smoothly! (So if anyone stumbles here looking for help, this is clearly the patch you’re looking for).



Please add it to the wiki if you have time. It’s much easier to find information there than searching through dozens of posts in these forums.


bobocat, I had never edited the DH wiki. So, it is possible that this does not fit into edition guidelines or whatever.

Anyway, I guess that now it will be easier to find for the next one looking for an answer :slight_smile:


cool! something is much better than nothing.


I just installed as per the wiki and the .htaccess file in the ownCloud installation directory already includes the env flag rewrite rule /but/ without the L. There are other *dav rules after that line that appear to have been added by ownCloud.

However, I can’t view files on the android app after connecting successfully, which i understand needs webdav. Also, while the OSX client works, the Linux client fails to download any files.

I’m at a loss and any help would be very welcome.