Outgoing email being blocked/junked

conspiritech:
I am NOT sending unsolicited email AT ALL. The only email that gets sent is:

  1. a notification to verify a new registration (which I have now bypassed–people can log in without a valid email)
  2. when people request a password
  3. notifications that another member has sent a private message.

The site is only a message board / forum. We don’t advertise, it’s a non-profit. We’re talking less than five emails per day!

I am so sick and tired of this email mess, I really wish I had never moved the site to DreamHost.

Why can’t all the slick programmers at DreamHost figure out a way for my site to send email using its own IP address?

Use a GMail account and SMTP.

I’m not sure what that all means. I registered for your forum and had no issues with it being flagged (gmail). Maybe if you post some of the info from the panel > mail >manage email and other ‘mail’ pages someone will spot what is wrong.

OP’s emails are being cock-blocked by some mail services due to it originating from DH email servers.

Conspiritech, gmail is ok. It is yahoo, aol and hotmail that are the turds.

Even if you use one of the three email addresses, you can register, since I have turned off the “email verification” requirement. So registration works regardless.

But if anyone tries to request a password (due to their forgetting), or another member sends them a “Private Message”, I get notification – three days later – that their email notification was refused.

“Cock-blocked” as sXi calls it.

I have even used my aol and hotmail email account to complain to those hosting services, and all I get from them is a runaround like reporting it to the site host.

Stevec can you easily configure your forum software to use a gmail account or google apps account for sending out its email?

I stopped having trouble when I did this. I don’t know how easy this would be in UBB. In SMF for example it is easy. In ‘Administration Centre » Mail » Settings’ put

Mail type = SMTP (instead of the default which is PHP)
SMTP server = ssl://smtp.gmail.com
SMTP port = 465
SMTP username = myAccount@gmail.com or anything@myGoogleAppsDomain.com
SMTP password = myPassword

Voila. No more blocked emails.

I think this is what Elle S meant by “our web hosting and cloud services are our main focus, and if our email services fail yours and your clients’ expectations too often, it may be worth looking into specialized mail hosting services for your domains”.

Thanks, tomtavoy. I will definitely give that a try.

I had this kind of trouble with another shared hosting provider… I’d notify them of the blacklisting, and they’d go and remove the blocks, but within a few weeks, the ips of the webserver /mailserver would be back on the block lists.

One option I found was to get an account with a provider like elastic email. It is priced pay as you go in the range of 1,000 emails for a dollar. I had to put in a minimum credit deposit of 20.00 but for personal use, I don’t expect to ever run that down.

Just be aware, when you first sign up, THEY WILL put you on a less reputable IP range until you can prove to them that you aren’t a spammer… then they’ll move you to one of their better IPs. I found this out after getting blocked and they told me this and then moved me to the better ip.