Os X FTP


#1

Anybody have any luck using “Connect to Server” in the Mac OS X finder to upload/download files from their domains?

I can connect to my site + have it appear in the Finder, but attempting to upload + download files results in a permissions error.


#2

Wow! I didn’t know that worked! And it’s not FTP; it’s AFP. And it works for me. I connected to my domain and used sdayman for my username, then typed in my password and I was able to upload and download.

Are you typing plain old ‘www.yourdomain.com’ for the server address? If you’re using ftp://www.yourcomain.com, OSX just isn’t set up to do that well. It can download, but not upload.

-Scott


#3

I was using ftp:// originally. I tried afp:// and it connects, but fails to authenticate (incorrect login/authorization, even though the id+pswd are correct).

I tried two ways:

afp://@domain.com
and
afp://domain.com

both with the same results. Is this the format you’re using?

The user I’m logging in as has FTP and shell/telnet access. I’m not sure if I’m missing anything else in my domain setup…


#4

I didn’t type in afp:// I typed only www.MYDOMAIN.com and it did the rest. I used my Username and its associated password. This works for all the FTP users and their respective domains that I have.

-Scott


#5
  1. Mac OSX’s FTP support is read-only
  2. Yes, I have. You need to enable WebDAV on your DH account. Then it is easy.

#6

This does not work for me - I only get connect errors. AFP never connects and also warns me that i’m sending my password unsecured.