Only When I'm Not logged In, do the links work



The issue is that my links don’t work when I am logged into my WordPress site.
BUT the links do work when I am logged out of the site.

I’ve tried different computers at different locations, like at the Library.
I’ve tried different browsers but this didn’t make a difference.

I deactivated all my plugins. I set my permalinks to default.
Both my WordPress Address(URL) and my site address are the same.
I tried removing the www. before the addresses.

It’s been a month and I haven’t found help at WordPress forums.

I just want to click “view site” on the upper left hand corner of my Dashboard to see that the page is working, but it doesn’t work unless I log out.

Also, the message box is different when I’m logged out. There is only 1 box/space when I’m logged in. You’ll see four spaces, logged out.

Any ideas?

My site is
At there are 3 links at the top of the page.

Thank you.


What do you see when you’re logged in? A blank white page? An error…? You get the idea :slight_smile:

This is an excerpt of your source code for that page:

<p><a href="#september202013">September 20, 2013,</a></p>
<p><a href="#maingoals&plans">Main Goals & Plans</a></p>
<p><a href="#immediategoals">Immediate Goals</a></p>
<p><span style="color: #ff0000;">Finish Publishing the Children’s Book*</span></p>
<p>Build New Technology</p>
<p><span style="color: #ff0000;">Improve Reading Comprehension*</span></p>
<p>Finishing This Site</p>
<p><span style="font-family: 'Helvetica Neue Light'; font-style: normal; line-height: normal;">Go To Groups/meet ups/or individuals</span></p>
<p><span style="color: #ff9900;"><span style="color: #323333; font-style: normal;">Improve my physical health</span></span></p>
<p><span style="font-style: normal; color: #ff2500;"><span style="color: #ff0000;">Set-up financial infrastructure</span></span></p>
<p><span style="color: #000000;"> Set-up Personnel infrastructure</span></p>
<p><span style="color: #323333; font-family: 'Helvetica Neue Light'; font-style: normal; line-height: normal; font-size: 16px;">Make a list of required positions jobs</span></p>
<p><span style="color: #323333; font-style: normal;">As Time Goes By 8-11</span></p>
<p><a name="september202013"></a><span style="text-decoration: underline; color: #ff9900;">September 20, 2013;</span></p>
<p><a name="maingoals&plans"></a><span style="color: #c0c0c0;">Main Goals & Plans></span></p>
<p><span style="color: #c0c0c0;"> <a title="Other thoughts Sept 9.'13" href=""><span style="color: #c0c0c0;">other thoughts.</span></a></span></p>
<p><span style="text-decoration: underline; color: #ff9900;">Starting  September 23, 2013</span></p>

In that, everything that IS a link looks correct. Seeing code strings with “font-style: normal” though makes me wonder if you accidentally copy/pasted straight from a Word Doc…



Thank you for your Great suggestion of comparing the two page sources!

The source code, while I was logged in, was exactly the same as your excerpt, except for code for ’ in place of ’ And a spelling error that was on both your copy and mine.
I corrected the spelling error but there wasn’t any change.

I also quickly scanned the rest of the code on the page but I didn’t see anything that looked like errors.

Re: Word Doc, I typed everything word by word, just like right now; I didn’t use copy & paste from anything.

I guess I will compare the rest of the code space by space, before and after your excerpt, unless there’s a better suggestion?

Thank you. :slight_smile:


You’re putting in stuff like this:

<p><span style="color: #ff9900;"><span style="color: #323333; font-style: normal;">

By hand on purpose? That’s … not really the best way to do it.


Hi. Thanks for your continued support.

The only code I put in was for the links.
I didn’t add anything like the code you show, "

<span style=color…"etc. I don’t even know what that means, other than guessing.
All my changes in color were done on the “visual” page (not “text” or code). I high lighted the words to be changed to different colors, then clicked the “A” (Select text color), and clicked the box containing the appropriate color.

Actually, I remember now, adding something to the editor, when I read someone’s advice about changing the size of the message box. I don’t remember what I did. It seemed to make the box slightly smaller for a little while.

Also, I did accidentally leave the site open to anyone, for about 24 hours, about a month ago, and one person did sign up as administration, if I recall correctly, so this person could have added something. (I removed this person’s name and access immediately.)

I’ll gladly change or remove anything that needn’t be there.

Thank you.


I don’t normally suggest this, since it does weird things to formatting, but I want you to edit that post and then click on the TEXT tab for the editor, so you see the HTML view, instead of the pretty GUI.

In that view, check that you actually have links there. They’ll be like this:


The way you described, to not normally add links, is the only way I could figure out how to make them work.

On the 2nd line from the top of the page, I added:

"September 20, 2013,

About 20 written lines down I have:

"September 20, 2013;

I also want to reiterate that the message boxes on all the pages are the same when I’m logged in(one box with one space), and all look different when logged out (one box with 1 large space and 3 small spaces).

Thanks again for your help with solving this puzzle!


Okay, so … the fact that you got code like that span line means that you (or someone) unknowingly pasted in formatted content into the Visual Editor.

The only real fix here is to re-do that page in PLAIN html and see if that works. Don’t use any of those spans, just make the plain page work first.



I don’t know how to do HTML :l (just started learning). I only learned how to do the links from searching the web.

I somewhat did as you asked; I typed in a copy of (half of ) the same page on a new page, then clicked Publish.

Afterwards, I clicked Text to check out the code and there were span lines there.

The 2nd line from the top of the page shows:

" September 20, 2013, "

So I removed the underlines shown in the Visual, then clicked Text and the span lines were gone.
I’d rather like to keep the lines under some words.
Also, I’d rather not rewrite the whole page with all its links if the text is just going to look the same. :slight_smile:

The only time I saw span lines in the text of the new page, is where a line like the above line, is used in reference to underlining a word(s).

Are the following lines, with their long numbers, I found on Page Source, normal?


8. Make a list of positions (jobs) co-ordinated with a list of blank spaces and candidates/volunteers/contracted workers, to fill the positions for:

-the book


Thanks Again.


Nope. Not normal.

Normal is this:

[code]8. Make a list of positions (jobs) co-ordinated with a list of blank spaces and candidates/volunteers/contracted workers, to fill the positions for:

-the book

No p tags, no spans. Just plain stuff.

Kind of like writing a post here :slight_smile:



So I have to delete my account, open a new account, re-install, and manually type in everything (because my backup will have the same crazy code on it)?

Maybe I could do a test first, by changing my setting on DreamHost to multi site and then downloading my same theme, twenty eleven, to that site before I go about deleting all my work.

Do you have any more ideas?

Thank you for all your help Ipstenu!
(due to the time of the year, it’s likely to be several days before I get to trying out the multi-site test.)



Take a deep breath.

When we talk about ‘reinstalling WordPress’ we actually just mean deleting the WP core files, never ever your content. But here? Not talking about that at all. Nor would I talk to you about Multisite yet (it’s not easy to use, and frankly, I don’t think you’re ready to maintain it if your thought right now was to delete and manually type in everything).

So let’s go back.

The HTML you’re putting in is all janky. So on the pretty GUI view, I want you to do this:

  1. Select all the content and hit copy.
  2. On the editor row, click on the kitchen sink icon (look at - on the Row 1 explanation, it’s item #15) and make sure that the second row of icons is showing.
  3. Click on the T icon (next to the W) for PLAIN TEXT
  4. Enter your text in this box:

That will convert everything to plain, simple, HTML. Then you can add a link and see it if works :slight_smile:

If you really are into Multisite, please grab this ebook - - It’s $7.98 but if you use the coupon PWYW it’s free (use the code PAY50 if you wanna pay half off, those are permanent coupons, good for anyone forever). Multisite is NOT EASY. It’s going to expect you know how to get in and manipulate files on the server by hand, and you’re going to have to start getting familiar with code, so I really liken it to jumping off the high dive the day you learned to swim :slight_smile:


Sorry for the delay-password issues.

I did as you suggested.
The result earlier this week was that all the links disappeared, I was unable to get a link working, I could only see, approximately, the first 10 lines of the page, “PLANS & GOALS(old)” and all of the double spaces between the paragraphs were changed to quadruple spaces ( I have since changed the first several lines"

Today, after messing around with trying to get a link to work, all contents of the page suddenly reappeared, though the quadruple spaces remained.

I just now went to the page to copy the links and noticed the 2nd part of the link (landing link)had disappeared!
Earlier, today, the" "had moved to the middle of the link line without my manually moving it.
And the &nbsp appears without me putting it in or wanting quadruple spacing.

Just now, I replaced the landing link, and the link almost works; it lands one space past the designated landing link line.
Here is what I have:

"links on this page aren’t working.

September 20, 2013

Main Goals & Plans

Immediate Goals

Finish Publishing the Children’s Book*

Build New Technology

Improve Reading Comprehension*

Finishing This Site

Go To Groups/meet ups/or individuals

Improve my physical health

Set-up financial infrastructure

Set-up Personnel infrastructure

Make a list of required positions jobs

As Time Goes By 8-11

September 20, 2013"

Also, the message box is still different than what is shown when I log out.
The link, though not working properly, has stayed in place during the last 10-15 minutes. Is it normal for code to change after 10 minutes?

Do you know why the link is landing one line below the link?

Thanks for your help and patience!


You’d think things would be slow here over the break, but noooo lots of projects to catch up on! Sorry about the delay.

No, not normal at all.

So this link is a special link:

Normally you don’t need the #, but when you have it, it uses the ‘name’ clause to position itself. When you’re logged in to WP, you have the black toolbar, which adds extra spaces in things (in a weird way - adjusting code to be ‘perfect’ when you have a fixed menu bar is something that drove me up the wall two months ago). Anyway, that link should take you to here:

And it’s doing so, but with an extra space?

By the way, when I go to the page refreshes over and over


I looked at my links code and saw that they are exactly the same as you wrote above. I guess i just accidentally hit the ’ " ’ button at the end of the “<a name…” line on the above copy.

I couldn’t get the links to work, either logged out or logged in. As you saw, the page refreshes over and over.

Any guesses why?

I’m learning a few things, which is nice but it seems like we’re not solving the issue, and in fact we have another issue - the page refreshing over and over. I connect fine with other sites. For Eg.… is fine.

Shall I add you as an administrator? so you can take a look inside?

Regardless, i will try to view the site tomorrow. Maybe some glitch will be resolved.


Hi, I added the backward slashes :slight_smile:

The page is still refreshing continually. That’s about 14 1/2 hours since I last checked.


I just added the backslashes to the links :slight_smile:

The page is still refreshing over and over.


Besides the continued site refresh,

there is a grid on all of the pages that I can view when I’m logged in.
Sometimes the numbers increase when I scroll down and the opposite when I scroll up. This appeared at about 9:30 pm or 45 minutes ago.

Also there are spelling errors on the Browser compatibility page under Settings. This makes me think that the Theme builder did not build the page that I presently see.

When I click view site, I still see the grid, even as the page continues to refresh.

I ran through one of those sites that detect malware etc. But nothing was detected. I found the site via a link from support.

I’m planning to post this somewhere on support.

So, what do you think now?
Re-install? :slight_smile:
Also the Wordpress icon on the upper left hand corner, was green. Now it has returned back to the normal color of black.
The grid has now disappeared also. Seems like someone just read what I wrote. Or maybe I’m crazy?


I’ve now de-activated the Browser compatibility, and the page refresh has stopped!
I tried your special links but they only led to a 404 page.
I removed the slashes and found again that the links work but it lands one space past the intended landing line/link.