One-click install of oscommerce failing


#1

I’ve tried twice to instal osCommerce using one-click and it fails–I wait my ten minutes and then the following shows up under Support. Any idea why?

From: DreamHost Installer Robot support@dreamhost.com
Subject: There was an error while installing oscommerce on your site!

We were unable to set up oscommerce as requested at:
http://www.rainn.org/donate/

The problem was we couldn’t download the osCommerce installation files!
Please wait a little bit and attempt to re-install it again later.

Please correct this and go to our web panel and re-submit your
oscommerce installation request.

Thanks, and sorry about that!
The Happy DreamHost Installer Robot


#2

DH pulls the installation files directly from the OS commerce server, for each install I believe. That way they don’t have to worry abotu updating their system each time a new install is aviable.

And the mesage you’re getting looks like there is an issue with the OS commerece servers. Wait a bit ( an hour or two) and try it again.

-Matttail


#3

Ah, that makes sense.

I’ll try later and see how it goes.


#4

It seems to me that this may actually be a larger problem–I don’t seem to be able to do DNS resolution for any domains. This is a new server. Is this a contact support kind of thing or is this something I can resolve on my own?

$ nslookup oscommerce.com
Note: nslookup is deprecated and may be removed from future releases.
Consider using the dig' orhost’ programs instead. Run nslookup with
the `-sil[ent]’ option to prevent this message from appearing.
Server: 66.33.216.208
Address: 66.33.216.208#53

** server can’t find oscommerce.com: REFUSED

$ host oscommerce.com
oscommerce.com A record query refused


#5

I am able to do this via telnet connection. I tried “host google.com” as well as “host oscommerce.com” and both returend with IP address. If it’s still not working for you I would endeed contact support.

-Matttail


#6

I contacted support. Hopefully it’ll get resolved soon.

Thanks!


#7

did this ever get resolved or did you move host?


#8

you can always just go to http://oscommerce.org/ - go to the downloads page and download the Linux/Unix Package. open the package, upload the files to the root you want the store installed and then follow the directions. your DB was probably built when you tried to have dreamhost install it so use the info that you entered in.

it’s the exact same thing as what dreamhost offers but the only difference is that you are uploading the files to your site and not dreamhost.

i’ve installed it myself before dreamhost offered it as a on click install and i just recently used the one click install.


#9

it got resolved very quickly. turns out it was a DNS issue, which meant i couldn’t download it myself from oscommerce (which was my next step).