Not seeing rich editor in Wordpress

apps

#1

I just signed up for Dreamhost and used 1-click install to install Wordpress. When I go to “Write Post”, there is no rich text editor. I know what the editor is supposed to look like, since I’ve used Wordpress.com. And at the bottom of the page, it says I’m running Wordpress 2.1 (which, as I understand it, is supposed to have a rich text editor). I can’t find any option which references it. Others have mentioned the “Use the visual rich editor when writing” checkbox, but I can’t see it anywhere. Is it possible I got a bad version of Wordpress? Any suggestions?


#2

Rich Text Editor does not work with every browser, for example Safari. Use Firefox.

'Use the visual editor when writing’
http://yourdomain.com/wp-admin/profile.php


#3

You’ll find the option to turn it on under Users in the WordPress dashboard. When you get there, click on the Your Profile tab and you’ll find it.

But I have to tell you that it doesn’t work very well, and you may still not see the option, or see only some of the options. This is apparently a known bug with WordPress 2.1, so I wouldn’t be surprised to find a 2.1.1 out eventually.

And as the other person mentioned, the rich editor doesn’t function properly in Apple’s Safari browser or others using the same rendering engine (such as OmniWeb).

Peace,
Gene Steinberg
Co-Host, The Paracast
http://www.theparacast.com
[b]My DreamHost Promo Plan—Use the code: [color=#CC0000]ROCKS[b][/color]


#4

Thanks! That worked!


#5

Another option is to use a seperate editor. I currently use a plugin with quite a few more options available. This can be used until they fix the bug in Wordpress.

The plugin is: Xinha4WP
http://baptiste.us/plugins/xinha4wp/

Just a thought.

Save [color=#CC0000]$97[/color] on Dreamhost plans by using promo code: [color=#CC0000]SRVR97[/color]