Not Enought Disk Space on Server


#1

I am trying to upload some updated pages to my site and have encountered the error message from Dreamweaver:

“An FTP Error Occured - cannot put [filename]. There is not enough disk space on the server to perform this action”.

My account allows 800MB of disk space and I am currently using just over 67MB so this error message makes no sense.

I tried to upload files using IE 6 SP2 FTP client and get a similar error message:

"An error occured copying a file to the FTP server. Make sure you have permission to put files on the server.

Details:
200 Type I
227 Entering PAssive Mode (66,33,222,33,163,190)
150 Opening BINARY mode data connection for [filename]"

Again this makes no sense as I have sucessfully deleted files and uploaded files in the same session, without problems until now.

Nothing I do (deleting files) helps as I continue to get the same error messages and am prevented from uploading any new files to the server.

This is the first time I have seen this message and have no idea why I am getting it or how to resolve the issue.

Please help.

Thanks,

Krism


#2

Thanks Bob.

After getting a reply from Dreamhost Support that there was nothing wrong with FTP I took one of your suggestions (examining the quota) and looked into it more closely.

It turns out (and I am wondering if I am the only one to have been caught out here) that when you create an FTP user account and your follow the prompts and also create an email address associated with the account, if you put a quota on the email address it automatically applies to the FTP account as well.

For example I created an FTP user BLE and an email account called “bounce” (thinking that I could catch all “bounced” email using this address). I set the quota for the email account “Bounce” to 10MB so all that spam would not saturate the “bounce” inbox.

Little did I know that in doing so I also set the disk quota for FTP user BLE to 10MB which meant that FTP user was only allowed 10MB of disk space, since my web site was mapped to this FTP user my Web Site was restricted to 10MB.

Hence all the errors I was getting.

Removing the quota restriction on the bounced email account also lifted the quota on the FTP user BLE.

Now everything is working wonderfully.

Anyway I thought I’d post a follow up as I think this mistake could be easily made and is very frustrating if you (like me) didn’t have a clue what was causing the restrictions.

Thanks for your suggestions bob it helped me focus my attention in the right area.

Cheers,

Krism