Normal PS Activity?


#1

As far as I know, I’m not using ssl for this client’s account.
I was doing a top -c, shift m and saw the below.
(Users and ps numbers munged.)
Is this normal?

14876 root 20 0 219m 28m 18m S 0 3.6 0:33.47 /dh/apache2/apache2-ps#####/apache2-ps#####-httpd -DModSSL -d /dh/apache2/apache2-ps##### 11142 dhapache 20 0 219m 11m 1780 S 0 1.5 0:00.03 /dh/apache2/apache2-ps#####/apache2-ps#####-httpd -DModSSL -d /dh/apache2/apache2-ps##### 16490 dhapache 20 0 219m 11m 1712 S 0 1.5 0:00.00 /dh/apache2/apache2-ps#####/apache2-ps#####-httpd -DModSSL -d /dh/apache2/apache2-ps##### 16509 <user 2> 20 0 118m 10m 6484 S 0 1.3 0:00.02 php5.cgi 10322 dhapache 20 0 219m 9840 752 S 0 1.2 0:00.32 /dh/apache2/apache2-ps#####/apache2-ps#####-httpd -DModSSL -d /dh/apache2/apache2-ps##### 10319 dhapache 20 0 207m 9376 376 S 0 1.2 0:00.00 /dh/apache2/apache2-ps#####/fcgi-pm -DModSSL -d /dh/apache2/apache2-ps##### 15186 root 20 0 70504 3256 2560 S 0 0.4 0:00.01 sshd: <user 2> [priv] 28882 root 20 0 70504 3256 2560 S 0 0.4 0:00.02 sshd: <user 1> [priv] 10207 postfix 20 0 39272 2400 1904 S 0 0.3 0:00.00 pickup -l -t fifo -u -c 29764 <user 1> 20 0 17812 1940 1396 S 0 0.2 0:00.01 -bash 15587 <user 2> 20 0 17740 1860 1392 S 0 0.2 0:00.00 -bash 29745 <user 1> 20 0 70504 1724 1024 S 0 0.2 0:00.05 sshd: <user 1>@pts/0 15582 <user 2> 20 0 70504 1608 912 S 0 0.2 0:00.00 sshd: <user 2>@pts/1 13801 <user 1> 20 0 18980 1252 996 R 0 0.2 0:00.29 top -c 15051 postfix 20 0 39432 1160 1012 S 0 0.1 0:02.56 qmgr -l -t fifo -u -c 14782 root 20 0 116m 1056 884 S 0 0.1 0:13.29 /usr/sbin/rsyslogd -c4 15041 root 20 0 37208 968 872 S 0 0.1 0:02.61 /usr/lib/postfix/master 14833 root 20 0 20948 752 636 S 0 0.1 0:05.50 /usr/sbin/cron 1 root 20 0 8404 740 608 S 0 0.1 7:16.66 init [2] 15047 root 20 0 49216 624 504 S 0 0.1 0:06.19 /usr/sbin/sshd 14806 root 20 0 22792 568 540 S 0 0.1 0:00.05 /usr/lib/courier/courier-authlib/authdaemond 14950 nobody 20 0 141m 528 452 S 0 0.1 0:10.53 proftpd: (accepting connections) 14799 daemon 20 0 18756 392 340 S 0 0.0 0:00.02 /usr/sbin/atd 14804 root 20 0 6176 352 348 S 0 0.0 0:00.00 /usr/sbin/courierlogger -pid=/var/run/courier/authdaemon/pid -start /usr/lib/courier/courier-authlib/a 14808 root 20 0 22792 24 0 S 0 0.0 0:00.04 /usr/lib/courier/courier-authlib/authdaemond


#2

All looks normal to me. -DModSSL is always set for historical reasons.

(We used to have some servers with SSL only enabled on certain Apache processes. This is no longer the case, as the overhead of loading ModSSL is basically zero now, so it’s just turned on everywhere.)


#3

Thanks, andrewf.
That’s what I needed to know.


#4

Was wondering about this as well as it seems to be loaded quite often when I visit the site.

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND 24516 domainuser 20 0 184m 74m 24m S 29 5.3 0:14.44 php5.cgi -c /dh/etc/php-ini/domain.com.17797728/php.ini 24515 domainuser 20 0 184m 74m 24m S 10 5.3 0:07.19 php5.cgi -c /dh/etc/php-ini/domain.com.17797728/php.ini 26766 dhapache 20 0 416m 11m 3172 S 6 0.8 0:00.19 /dh/apache2/apache2-psxxxxxx/apache2-psxxxxxx-httpd -DModSSL 2068 root 20 0 145m 9948 944 S 0 0.7 0:22.45 /usr/bin/python /usr/bin/supervisord 21646 admin 20 0 19120 1300 984 R 0 0.1 0:01.62 top -c 26521 admin 20 0 45096 8816 2528 S 0 0.6 0:00.28 /usr/bin/perl /home/admin/bin/psmanager.pl 26768 dhapache 20 0 0 0 0 Z 0 0.0 0:00.01 [apache2-ps13142] <defunct> 1 root 20 0 8404 772 636 S 0 0.1 1:39.09 init [2] 2266 daemon 20 0 19016 384 220 S 0 0.0 0:00.00 /usr/sbin/atd 2297 root 20 0 124m 1048 792 S 0 0.1 0:00.82 /usr/sbin/cron 3585 root 20 0 335m 18m 10m S 0 1.3 0:06.10 /dh/apache2/apache2-psxxxxxx/apache2-psxxxxxx-httpd -DModSSL 3921 postfix 20 0 39440 2356 1868 S 0 0.2 0:00.18 qmgr -l -t fifo -u -c 14890 root 20 0 70512 3236 2536 S 0 0.2 0:00.04 sshd: admin [priv] 14894 admin 20 0 70512 1484 788 S 0 0.1 0:00.13 sshd: admin@pts/0 14895 admin 20 0 17744 1888 1416 S 0 0.1 0:00.02 -bash 21209 dhapache 20 0 334m 7852 348 S 0 0.5 0:00.00 /dh/apache2/apache2-psxxxxxx/fcgi-pm -DModSSL 21328 dhapache 20 0 335m 8164 644 S 0 0.6 0:00.17 /dh/apache2/apache2-psxxxxxx/apache2-psxxxxxx-httpd -DModSSL 23602 domainuser 20 0 175m 64m 24m S 0 4.6 0:21.01 php5.cgi -c /dh/etc/php-ini/domain.com.17797728/php.ini 23671 domainuser 20 0 172m 62m 24m S 0 4.5 0:16.76 php5.cgi -c /dh/etc/php-ini/domain.com.17797728/php.ini 24519 domainuser 20 0 188m 74m 24m S 0 5.3 0:21.98 php5.cgi -c /dh/etc/php-ini/domain.com.17797728/php.ini 25293 nobody 20 0 142m 1792 604 S 0 0.1 0:01.78 proftpd: (accepting connections) 26518 root 20 0 134m 1032 740 S 0 0.1 0:00.00 /USR/SBIN/CRON 26520 admin 20 0 9108 1116 936 S 0 0.1 0:00.00 /bin/sh -c $HOME/bin/psmanager.pl >> /tmp/psmanager_cron.log 26690 dhapache 20 0 424m 11m 3216 S 0 0.9 0:00.22 /dh/apache2/apache2-psxxxxxx/apache2-psxxxxxx-httpd -DModSSL 26709 dhapache 20 0 416m 11m 3120 S 0 0.8 0:00.17 /dh/apache2/apache2-psxxxxxx/apache2-psxxxxxx-httpd -DModSSL 26769 dhapache 20 0 343m 10m 2680 S 0 0.7 0:00.00 /dh/apache2/apache2-psxxxxxx/apache2-psxxxxxx-httpd -DModSSL 27409 root 20 0 121m 1488 1064 S 0 0.1 0:01.84 /usr/sbin/rsyslogd -c4
But I guess that is no big deal as it does not use that much memory. Trouble shooting here as I have regular odd reboots…