Nodejs express async not working


#1

Guys, I have this error in my site. its seems Phusion doesn’t accept async and await. How do I run this.

An error occurred while starting the web application. It exited before signalling successful startup back to Phusion Passenger. Please read this article for more information about this problem.
Raw process output:
/home/bonarvind/boozeyum.com/routes/index.js:8
router.get(’/’, async function(req, res, next) {
^^^^^^^^
SyntaxError: Unexpected token function
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions…js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Object. (/home/bonarvind/boozeyum.com/app.js:17:19)
at Module._compile (module.js:460:26)
at Object.Module._extensions…js (module.js:478:10)
Error ID
9e676fec


#2

Your passenger may not be queuing up the correct version of node? I ran into a similar problem once and I had to add a config file to point passenger at version 8 instead of whatever version it was using.


#3

Relevant article :smiley:

Look under troubleshooting