No such file or directory


#1

Hi,
I have a ticket submitted but my guess is that I will be waiting a minimum of 24 hours on it.

A while back say 6 months maybe more, when I would use the joomla one click installs the confirmation email would include a few steps required for the installation to be a success. One of these steps entailed the removing of the .something in the server path that was automatically filled in. You removed the .something and continued entering the other necessary info such as hostname and sql db user name and password and it worked like a charm.

Now, that step to remove the .something is no longer a part of the setup process.
Recently I installed a new template ‘successfully’ according to the installer, but when I tried to view the template I will saw the error…
No such file or directory in /home/.something/user/domain/blah blah. This only sometimes happens. I switched back to the previous template and it works fine…not the one I want though…

More importantly…I just tried a Joomlart Quickstart Installation.
After inputting my usual info…localhost, db, username, password and hitting enter I don’t get the next screen of the installation setup, instead I get the
No such file or directory in /home/.something/user/domain/blah blah

It’s the .something that is driving me nuts. My guess is that there’s nothing I can do on my end, but just wanted to make sure.

Thanks.

Chunky


#2

I just wanted to update and mention that support told me to simply use the one click install and that the .something had nothing to do with whatever problem I was having.

This obviously doesn’t help me. I really do think the .something is getting in the way somehow…just don’t know how to get around it.

Thanks for any assistance.

Chunky


#3

Chunky,

That “.something” is was DreamHost calls a “dataglob”, and it should have no impact on your site in normal use.

Note that I said,“should”, because it can cause things to be messed up IF you include that information in paths in scripts and DreamHost should change it for any reason.

your /home/username dir is actually a symlink to /home/.dataglob/username/ . Therefore, it is far “safer” to not use it all all (use /home/username instead!), so that if DreamHost should move things around on the server and change your dataglob, you rscript will still work.

I don’t want to say that support is wrong, but if your dataglob has changed, and your Joomla! installation actually has the dataglob included n the paths in the configuration, that could indeed be creating “not found” conditions.

If you don’t already have a lot of data in your Joomla! installation, what I suggest is to just delete it and start over from scratch. Clear your caches and DO remove the “.dataglob” information from the paths in the new installation, and see if that straightens everything out.

–rlparker


#4

Thank you.

Where would I change that though or at least see what the path even looks like…now the one click installations do not allow you to even see the path anymore. And, for the non one click installations like the joomlart quickstart I would like to use…do you know how I would look into that.

I guess it’s irrelevant that it’s joomlart…i would have this same problem with any manual installation.

I did notice that when i do use the one click installs, in the joomla admin panel, config settings show that .something in the temp path.

Thank you

Chunky


#5

Well there are only a few places that I have found that the dataglob shows if it is being used in Joomla! 1.0.0.x installations and it show in different places in Joomla 1.5. I am not at all familiar with the Joomlart quickstart thing - I’ve never used it.

The places where I have seen them viewable from the Joomla Back end:

Version 1.0.0.x
Global Configuration - Server - “absolute path” (not Editible)
Global Configuration - Cache - “Cache folder” (Editible)

Version 1.5.x
Global Configuration - System - System Settings - “Path to Log folder” (Editable)
Global Configuration - Server - Server Settings
Path to Temp-folder (Editable)
Meda Manager path display (Not Editable)

Of course, many of these can be edited /placed in the configuration.php file, without needing to enter the Joomla! backend at all.

The display of the dataglob in the path of the Media Manager file structure is a “new” development with version 1.5, and does not appear to be "changeable, but my initial thought is that it is derived “automagically” from the PHP environment variable instead of being set manually, so it should not be a problem (nothing will break if it changes, the display will just show the new “full” path).

–rlparker


#6

Thank you. Before I get in further over my head, here’s what I am getting…

Warning: require_once(…/includes/database.php) [function.require-once]: failed to open stream: No such file or directory in /home/.fay/user/sub.domain.com/installation/install2.php on line 19

Fatal error: require_once() [function.require]: Failed opening required ‘…/includes/database.php’ (include_path=’.:/usr/local/php5/lib/php:/usr/local/lib/php’) in /home/.fay/usere/sub.domain.com/installation/install2.php on line 19

Same answer?

Chunky


#7

[quote]Thank you. Before I get in further over my head, here’s what I am getting…

Warning: require_once(…/includes/database.php) [function.require-once]: failed to open stream: No such file or directory in /home/.fay/user/sub.domain.com/installation/install2.php on line 19

Fatal error: require_once() [function.require]: Failed opening required ‘…/includes/database.php’ (include_path=’.:/usr/local/php5/lib/php:/usr/local/lib/php’) in /home/.fay/usere/sub.domain.com/installation/install2.php on line 19[/quote]
Both of those errors are the result of the same problem: Your install2.php script cannot find the database.php file.

In the first instance it can’t find it at “…/includes/database.php”, and in the second case it could not find it in the “default” includes directory of your PHP installation. That said, let’s troubleshoot this step by step.

First, what is the actual directory referred to in the first warning message? Since “install2.php” runs from the Joomla! installation directory (which is “/home/.fay/user/sub.domain.com/installation/”), the directory the code is looking to find the file in is “/home/.fay/user/sub.domain.com/includes” (it is trying to find the file “/home/.fay/user/sub.domain.com/includes/database.php”)

That said, you can safely eliminate any concern about the dataglob being at fault or relevant to the error. Stating the path with the dataglob is just a characteristic of the PHP error reporting routine, and the code should work with, or without, the dataglob in the path. For the purposes of debugging this issue, “/home/.fay/user/sub.domain.com/includes” is functionally the same as “/home/user/sub.domain.com/includes”. :wink:

Do you have a file “database.php” in “/home/user/sub.domain.com/includes/” ? If you do not, then clearly that is the problem (an incomplete installation). If that file is missing (and you didn’t delete it!) then I’d be suspicious of the entire installation - if one file is missing many more are also likely to be missing.

Such a problem is, actually, pretty common with Joomla! installations in which the core files were extracted on one computer ant then uploaded to the server via FTP. Joomla! has a lot of files, and very often, for one reason or another, some will not be properly transferred in that massive upload of hundreds of files.

I’ve seen those developing using an instance of Joomla! installed on their own machine, and then trying to upload the “launch ready” site onto their production server via FTP running into this pretty often. To avoid this, I think they should install the Joomla! core, and extensions “on the server”, and just export the “staging” database from their “dev” system for future import to the “live site”.

This is why I always install Joomla! in the shell by using wget and tar rather than downloading the package to my computer, extracting it, and trying to upload it to the server with FTP. :wink:

At any rate, your next troubleshooting step is to locate that database.php file before doing anything else - if it is not there, you need to put it there and proceed. Just be aware though, as I said above, if you didn’t delete that file but it is not where it is supposed to be, I think you should treat your whole installation as “suspect”.

–rlparker


#8

Well that is most reasonable. I will check this out.

Thank you for your time and patience.

Chunky