No rails


#1

My website (www.fridayemails.com) has been generating a “Rails app failed to start” error since last night (UK Time). Contacted support who told me there was a problem they were working on. 16 hours on from my original request and it’s still broken. Anyone else affected by Rails problems?


#2

Mine is down, too. I know that yesterday they did some changes on my server (guilder), as suddenly rails disappeared! Then finally it reappeared, but with a new version:

[guilder]$ gem list rails

*** LOCAL GEMS ***

rails (1.2.3, 1.2.2, 1.1.1)

Earlier in the day we were using 1.2.1

My apache error logs (~/logs/…hostname…/http/error.log) are reporting this:

Cannot find gem for Rails ~>1.2.1.0

Hmm! I tried changing my RAILS_GEM_VERSION variable to no avail, so now I’m “freezing” Rails to see if that helps. I’ll let you know.

My suspicion is that some other gem is directly dependent on 1.2.1, and it’s now failing.

rodney


#3

Freezing didn’t seem to change anything, so I’ve sent off another support request to have them put 1.2.1 back.

Sure would be nice if the (1) announced they were upgrading, (2) didn’t bonk the old version, and (3) tested it.

rodney


#4

I have also emailed them again. This has been going on for nearly 24 hours now. Not very impressed.

You’d think they’d at least post on the dreamhoststatus.com site if this is a known problem.


#5

Same issue on my site. I only reported it a couple hours back – but still no response.


#6

Just received this from support :

"
The problem you’re experiencing is because we have upgraded Rails, and
apparently it’s affecting your setup, most likely because you didn’t
freeze your apps. We announced this upgrade on the 15th:
http://www.dreamhoststatus.com/2007/05/15/ruby-on-rails-123/.

I tested it and got this error:

pepsi: 01:18 PM# ./dispatch.fcgi

Cannot find gem for Rails =1.1.6:

Install the missing gem with ‘gem install -v=1.1.6 rails’, or

change environment.rb to define RAILS_GEM_VERSION with your desired
version.

According to our admin who handled the upgrades, in some cases, changing
the variable RAIL_GEM_VERSION to 1.2.3 (the latest) in your
config/environment.rb file will fix a broken install. In other cases
reinstall will be needed."

Changing the variable worked for me.

I don’t think that a posting on the status page is really the best way to warn people that their sites might go tits up. It’s not like I regularly read the status just to see if they’re gonna fiddle with my site. But at least I’m up and running again.


#7

Then you have no one to blame but yourself. I check the status page at least once or twice a week, and I don’t even run any mission critical sites. It’s not hard, and I believe you can even get email updates per new posts on there (don’t quote me on that, I don’t use it!).

Glad you got things working all the same :wink:


Chips N Cheese - Custom PHP installs and the like!


#8

So what is the point of this page, then? http://rails.dreamhosters.com/ That’s the first place I look, and it said nothing about outages or upgrades.

It’s nice of them to post a notice there AFTER the fact. :frowning:

rodney


#9

I’m not sure freezing would have helped, anyway. I froze 1.2.1 into my app this morning, and it had no effect.

Yet now, a few hours later, after they processed my ticket, my app works, with the frozen 1.2.1

Hmmm.


#10

The dreamhosters websites are NOT official (as far as I’m aware) DreamHost sites. I’m quite sure those are run by customers themselves. So I can see why you might be confused now, heh.


Chips N Cheese - Custom PHP installs and the like!


#11

Has this been resolved for everyone? I froze 1.2.3 and so far, no effect. Still belly up…

thanks all, a useful discussion when I’ve been pulling my hair out for the last 2 days.

UPDATE: Of course, just as I wrote that, it magically works again. Changing the RAILS_GEM_VERSION to 1.2.3 seemed to do the trick. Nice of them to (not) let us know.