No longer can upload files


#1

Dreamhost has been hosting our sailing club’s (newcastlesailingclub.org) web site for several years. EI upload files on a regular bases using Dreamweaver on my highend iMac.

Every now and then, for no reason at all, without touching or changing anything I can NO LONGER up load files-though my IT guy has no troubles.

The latest error message in part says "FTP error-cannot make connection to host. No response from server.

I have no problems connecting to the internet or sending or receiving emails on my iMac.

Why is this? How can I fix it? And prevent it from happening again?


#2

I suspect you’re being bitten by a change we made to our SSH keys: http://www.dreamhoststatus.com/2012/10/24/proactive-security-maintenance-new-login-keys/

The local info stored by Dreamweaver is not updated, and while most other applications will inform you of the new host key and prompt you to overwrite the old fingerprint, for Dreamweaver, you have to manually delete the ssh_hosts file in

If you delete the whole thing, it’ll have to regenerate when you connect to any sites. Or you should be able to just remove the line for your domain.


#3

I’m not sure that’s the solution. The entire error message reads

An FTP error occurred - cannot make connection to host.
Dreamweaver could not find the host “newcastlesailingclub.org:23”. This may be due to one of or more of the following reasons:

-The network cable is unplugged (it isn’t) or the network is down. Please verify that the network cable is connected and the networks is up (email and internet work just fine).

  • The FTP server is down (others can use it). Please verify that you can connect to the FTP server (I can’t) using another FTP program.

-The FTP host name is incorrect (newcastlesailingclub.org). Please verify the name is correct in the Site definition dialog box (?).

  • Accessing the server requires proxy settings that aren’t properly set (is this the problem?). Please verify that the proxy settings in the Site category of the Preferences dialog box are properly set (to what?), and that the Use Proxy option in the Site definition box are selected (I’ve tried 21, 22 & 23).

  • It is possible your FTP may be using a nonstandard FTP port (21) (is it nonstandard?) If you need to specify nonstandard port, enter the port number after the host name separated by a “:”

Are you familiar with Dreamweaver or do you know someone that is?)

Does any of this make sense? Does this help define the problem?


#4

You can’t connect, or you don’t know how to? If you can’t connect using other programs, are you sure you’ve got the right Username and password?

Also when did this start breaking?


#5

This doesn’t sound right. Port 23 is telnet, not FTP. The default port number for FTP is 21, and we have not changed it.

More importantly, it almost sounds as though Dreamweaver is treating the “:23” as part of your domain name. If you’ve explicitly entered the “:23” in a text box somewhere, can you try removing it?


#6

I’ve NEVER selected 23 for our port. That’s just what it reads. NOr have I entered it any where else. I removed 22 and that did not work. I entered 21 as the port and got this message

“An FTP error occurred - cannot make connection to host. Dreamweaver could not connect because server is down or not accepting connections.”

I’ve been using the correct password and username.

This problem started on it’s own over six weeks ago.


#7

Did you change the IP address of your domain (by moving to VPS or dedicated)?


#8

no to both.


#9

Since it’s random, the only thing that really comes to mind is that you have a network issue. Your IT guy may be able to help tracing down the errors on your internal network. Maybe you have packetloss causing a connection issue.

Next time it happens, if you have another FTP app (Cyberduck is free for Mac), try connecting via that right away. If they both fail, but you can get to the site, then it’s likely your network. If Cyberduck works, then it’s probably a problem with DreamWeaver (which alas, I know very little about :frowning: )


#10

I downloaded Cyberduck, set it up and tried it again. It did not work.

I got this message

“Unknown host key for newcastlesailingclub.org
The host is currently unknown to the system. The host key fingerprint is 09:4d:70:05:78:e7:0b:c1:a0:40:de:61:27:a7:36:9b.”

Ideas?


#11

Now that’s a better error message! (Why DreamWeaver likes to hide them I have no idea.) I have a feeling if you tried to SSH into the sever, you’d get the same error.

Open a terminal window (Applications>Utilities>Terminal) and at the prompt type:

cd .ssh
ls

That should contain a text file named known_hosts. You can open this in a text editor and remove the offending lines. Your IT guy may be able to help you with this change. All that does is remove the old stored data, and it’ll automatically write a new line for your domain when you try to reconnect. It may prompt you to save, and if so, you would want to.


#12

Can someone at Dreamhost confirm my username and password are still current and are not being blocked?


#13

You’ll need to open a support ticket for that one.

From what I can see, there’s an account that’s probably yours, it has access to FTP, and it’s not blocked.


#14

Is there anyone I can talk to on the phone to resolve this matter? It’s over a month now and I still cannot access our site.


#15

You can request a callback, however I don’t see that you’re the actual owner of the account (you have an FTP ID/password, but your ID is not that of the person who owns the account). You need to talk to them and either have them reset your password, or open a ticket with us. Since I can’t verify that you should have that access, I can’t do it for you here :frowning:


#16

After two months I still can no longer upload files to Dreamhost’s servers. I’ve tried everything suggested. Dreamhost’s responses have been slow, technical and incomplete. Anyone considering hosting their website here should seriously reconsider and go with one that has phone support. If I unable to upload our files in the next five dayes I’m going to recommend we find a new provider. If you’ve had the same trouble with their support should do the same.


#17

Additionally, he error message keeps saying it cannot find the host dreamhost.com

Is it suppose to say dreamhost.com or dreamhosters.com

If I have to change it how do I do that using the latest version of Dreamweaver on a Mac?

I cannot find a field to change it.


#18

poulouinc - I’m sorry the answers you were given were technical.

Two months ago, we had to change certain settings for security, and Dreamweaver is just really sticky about accepting that change (or apparently giving a human readable error message).

The change we made is detailed here: http://www.dreamhoststatus.com/2012/10/24/proactive-security-maintenance-new-login-keys/

Were you told about needing to delete the ssh_hosts entry in this folder on your mac?


#19

You shouldn’t be trying to connect to dreamhost.com - I’m pretty sure someone else owns that domain.

Try connecting using your own domain name.


#20

That folder does not exist. I am using Dreamweaver CS5.5.

THere is a Dreamwaver CS5.5 folder with a en_US folder and a Configuration folder with a fields.css file and a Stringes folder and a Style folder, BUT NO ssh_hosts file. NOR does any search find it any where.

Why can’t I get phone support on this since your changes caused the problem?