No input file specified


#1

My account was recently moved to a new server. Unfortunitely this caused one of my running sites to stop working. Looks like the issue is with my .htaccess file.

Any one know of any issues/updates that occurred that might cause this to suddenly stop working.

My .htaccess file:

Turn on URL rewriting

RewriteEngine On

Installation directory

RewriteBase /

Protect hidden files from being viewed

<Files .*>
Order Deny,Allow
Deny From All

Protect application and system files from being viewed

RewriteRule ^(?:application|modules|system|admin-app|index.php)\b - [F,L]

Allow any files or directories that exist to be displayed directly

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

Rewrite all other URLs to index.php/URL

RewriteRule .* site.php/$0 [PT]

Again, this only occurred after my account was moved to a new server.

Any help is appreciated.


#2

First, try your site without the .htaccess rewrites.

[quote]My account was recently moved to a new server. Unfortunitely this caused one of my running sites to stop working.
Any one know of any issues/updates that occurred that might cause this to suddenly stop working.[/quote]

  • Check for, and remove, any superfluous dataglobs that might be floating about in config or database paths.

/home/[color=#CC0000].dataglob[/color]/username/domain.com --> /home/username/domain.com

  • If you customised PHP for your site and have been moved from a 32bit to a 64bit server, you will need to rebuild PHP.

  • If you used any custom DNS settings, you’ll need to review them as the domain IP will have changed.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

Already tried removing the .htaccess file. Everything works after I do.

Should probably explain what I’m trying to do:
I want to route anything going to / to go to index.php like normal, but anything like /listings or /about to point to site.php/listings or site.php/about.

This is a dirty hack to get wordpress to run as the index and a PHP site to run as one.

No custom PHP settings or DNS changes either.


#4

[code]
RewriteEngine On
RewriteBase /

<Files .*>
Order Deny,Allow
Deny From All

RewriteRule ^(application|modules|system|admin-app) - [F,L]
RewriteRule ^(application|modules|system|admin-app)/ - [F,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule .* site.php/$0 [PT,L]
[/code]
Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#5

Thanks for your help. Got my index page working. Kohana still wasn’t responding to any uri request, but I was able to find out why.

I needed:
RewriteRule .* site.php?kohana_uri=$0 [PT,L]

Instead of:
RewriteRule .* site.php/$0 [PT,L]

Not sure what changed on Dreamhost but it works now.

Thanks again for your help. I appreciate it. I Don’t really understand mod_rewrite commands all that well.


#6

I’ve ran into changes like this before. The “site.php/SOMETHING” uses “PATH_INFO” technique for running php scripts which can be disabled in some config file somewhere (or not be available depending on how php is connected to apache). Having PATH_INFO break on me is one of the most likely scenarios I run into when moving scripts around.