"No input file specified." Wordpress Error


I recently moved over to dreamhost and am getting the following error when I tried to navigate to one of my post pages:
“No input file specified.”

This is only happening if I use a permalink structure of:

Which has been working on my other two hosts for the last couple years. If I change to one of the default ones I get a 404 error.

Any ideas on what is causing this?

How about if you leave off /index.php? Not sure about that U-character in there either.

Does it work if you change it to this:


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.

Doing that I get a 404 error.

I’m not sure what the U char is, but it’s not in the actual config options.

Does it not even work on the default setting, like example.com/?p=123? Or is it just a problem with the default name & date based options?

Also, how did you move it? If you did a backup from an older version, I’m not sure if you’d hit problems importing it into a fresh install.

I’d make sure you have everything backed up, just in case things get too screwy.

I’d probably try running /wp-admin/upgrade.php to see if it need to update your DB.

:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.

The default (?p=123) works. But none of the other options do. If I don’t use index.php I get a 404 error. If I use index.php I get the “No input file specified” error.

I tried the upgrade.php and it says that my database is up to date.

To backup, I did a mysqldump and then imported into mysql using the mysql command line.

This is how I’ve done it before with no issues.

Is there somewhere in the WP tables that it stores permalink information?

Have you tried re-building permalinks?


How do I do that?

Try going to Options -> Permalinks and click “update Permalink Structure” at the bottom just to “rebuild” things.