Nms formmail

Can anyone tell me how to configure nms formmail to work on Dreamhost? I have struggled with this for days. It seems that Dreamhost is using the nms script but has changed it so much that they can’t give it to me so I can change the config as I need it. When I go to the nms site and search for Dreamhost in the support area, based on their most recent replies to Dreamhost users they said they can’t help because Dreamhost has changed the script so much! I know many people have used this script successfully. Yet no matter how much I try, I can’t get it to work when I install it in my directories. Unfortunately I want to turn on some options that Dreamhost isn’t using. Is it not working because Dreamhost has the servers set up “special” somehow that the basic script fails? Or that it conflicts with what is already out there? Has anyone done this successfully?

If you set the “emulate matt’s code” option, it should work out of the box.

Other than that, it’s not too difficult - perhaps you could point out the specific points you’re having trouble with? Is it executing at all? Spitting out an error? Just returning an internal server error.

Could you explain in more detail what’s not working? Have you read through the kbase articles on debugging CGI scripts? 95% of the CGI problems customers encounter are due to file or directory permissions problems (#1 reason), or to DOS carriage returns (for instance if you’ve edited the file on a Windows machine).

[quote]Is it not working because Dreamhost has the servers set up
"special" somehow that the basic script fails?



Check out my support history and my error logs from yesterday. I kept getting the error page I had set up. I tried iteration after iteration and it kept giving “Premature end of script headers: /home/wiscweb/wisconsinwebwriter.com/cgi-bin/FormMail.pl failed to open log file”. I read everything I could find in Kbase, the nms site and documentation files and other resources like About.com. I tried it for hours and hours all different ways.

I don’t want to emulate Matt’s script due to the security problems. Per the Readme file from the nms script turning that on would create security holes and doesn’t allow for the more advanced options of the form.

I realize this should be simple. But it hasn’t been. I am not cgi/perl knowledgable which isn’t helping. But it seems to me that it should be usable “out of the box” and it isn’t working. As others have installed it on other hosts so easily, and I am not changing anything other than the few options at the beginning, why is this so impossible? It scares me that they replied on 8/27/2003 to another Dreamhost user the following : “Please contact your hosting provider for technical support. They’ve taken our FormMail and modified it, so we can’t really help.” Why was this modified so much if it is so “usable out of the box” on your servers? Sorry but after 20 or so hours dedicated just to this I am frustrated.

Have you resolved this yet?

I downloaded the compact version of the nms FormMail script and only updated the $mailprog and paramters for domains and e-mail addresses and it works fine with the simple form they have in their README file. What changes were you making?

:cool: Perl / MySQL / HTML+CSS

Seems to be working OK now… Did you figure out the problem?

[quote]Why was this modified so much if it is so “usable out of the box” on your servers?


I’m not quite sure what you mean. The version we use is heavily modified, but that’s only because we’ve made some ugly hacks to get it to work for all of our customers. Getting it to work on your site shouldn’t be difficult.

Thank goodness yes! I tried again (from scratch) and changed only the items you said. I have no idea why it works now. There are a few things I did differently. I left the -WT in the top line (I had taken out before based on what Kbase said the top line should be and I took the env_report hidden field out. I tried from scratch at least four times yesterday! I compared my 2 files (today’s which worked and yesterday’s) and in the @referers yesterday I put the “www” at the front of my site address? I also had extra spaces after the top line from trying to put the content-type and charset in.

I have no idea why, I wish I did so I would have learned from this! I tried to test variations again and once it didn’t work I couldn’t just take out the last change to make it work again. Only after I started from scratch once more did it work. Whatever!! Just thanks for taking back to the basics and the beginning. It worked!