Nginx and php > 5.3

vps

#1

Hi all. Can anyone give me a pithy explanation of how to install a version of php greater than 5.2 on a vps running nginx? I tried the shell script here: http://wiki.dreamhost.com/Installing_PHP5 but it failed with “configure: error: Cannot find libpq-fe.h. Please specify correct PostgreSQL installation path”. Even if that were to work, I’m not sure how to tell nginx to use it–I also tried softlinking $HOME/.php-launcher to /usr/local/bin/php-5.3, but that resulted in no php instances running at all. I’m cargo culting, but after a day of diligent searching I’m not finding any particularly useful cargo to cult. I’d very much appreciate any guidance.
[hr]
Update: I’ve managed to build php5.4 (by turning off the postgresql flags–looks like I could install that too, but I don’t want to go down the rabbit hole). I copied in the php-fastcgi script from http://wiki.dreamhost.com/Nginx#Nginx_and_Custom_PHP_Install, pointed it at my local php5.4 install, and it runs without errors. However, I end up with nothing different. It tells me it’s running php-cgi (from the appropriate path), but ps shows only instances of php5.cgi running. And phpinfo() shows that I’m still running 5.2.


#2

Solved! I had to use the fastcgi script and point .php-launcher to my new php. I hope this is useful to someone else.


#3

I know this is old, but I added instructions this week. See