Newbie's desperate cry for help installing script



Will do!


I am having the same problem upon set-up…

“sh: /home/robhakari/awstats/ /usr/bin/perl : bad interpreter: Permission denied”

here’s my cron says(its all one line):

0 3 * * * perl /home/robhakari/awstats/tools/ -update -awstatsprog=/home/robhakari/awstats/

i dont have a clue what is wrong. any help would be greatly appreciated


It looks right. Although it looks like a line break might have snuck in between and -dir=/home/… Try editing the cron job and see if there’s a line break there to delete. That’s about all I can think of.



I’ve tried everything I’ve read in this thread and it’s to no avail. I don’t know what’s wrong


Sorry. I wish I could help. Maybe Skybly will see your post and offer up some help. As it is, I’m still a newbie so I probably couldn’t see the problem if it hit me in the face. :frowning:


heres to hoping skybly will see this


1st… i must have copied someone else’s post with out thinking about it… i get this error
"sh: /home/robhakari/awstats/ /usr/bin/perl : bad interpreter: No such file or directory"

yes… all .pl files are chmodded to 755


I have installed AWStats according to the description here, and it seems to work.

My question is:
I want more information about the IP adresses that have visited my site, but I can not get the DNS lookup or geoip-plugins to work.

Do you have any info on what is possible at a default DreamHost-site?



well… im gonna attempt to reinstall and hopefully that will fix my problems


Everything has worked for me here, except that pico will not put the cronjob command on one line. Where do I insert -w in these instructions?

If I start pico with “pico -w” then “crontab -e”, I can write out the command on one line, but then when I save I’m prompted for a file name - which I’m not sure what to enter since previously it already generated a file name for me.

Help! I can’t get past this problem.


Ok, I’ve managed to get most of the way through the installation (you’ve been a super big help, Skybly!), and I’ve never used perl before in my life.

However, is not being created at all. I don’t understand, because when I run, I get a similar result to the one that’s posted in the FAQ at the Awstats site:

Phase 1 : First bypass old records, searching new record…
Searching new records from beginning of log file…
Phase 2 : Now process new records (Flush history on disk after 20000 hosts)…
Jumped lines in file: 0
Parsed lines in file: 4
Found 0 dropped records,
Found 0 corrupted records,
Found 0 old records,
Found 4 new qualified records.

but no is made.
The way I understood it, it was supposed to create that file. Did I get confused? Was I supposed to manually create it somehow instead?

If I try to run the commands again, it complains that the file doesn’t exist and I get the error:

Error: Couldn’t open log file “/home/username/statistics/” for writing : No such file or directory.

I’m using version 6.4.


Nevermind, reinstalling it all again fixed it, so I must have just mad some small error.


I just wanted to say thanks for this post. I’ve been trying to install Awstats for a while now, and have finally done it. Cheers!

My Path to Financial Freedom -


I know this was from a while back… but I just found it and was setting up AWStats on my servers.

I have 3 domains… I have it working on 2 but keep getting a denied permission error on the 3rd. I’ve checked the settings and permissions, they all look right… anyone have any suggestions?


Thx, Skybly!

I’m relatively new to putty, AWSTATS and DreamHost, but after 2 hours of following your installation steps and doing things, I finally managed to install AWSTATS, it appears :wink:

I created the stats for the first time, then I used
crontab -e

to create CRON jobs for two of my domains.

I have just a small question - when opening CRON I see:

…or something of the sort… Is this OK? :slight_smile:

I mean, what is this strange TMP location and letters which change after each time? (crontab.XXXXXX) ?


You have created a very good tutorial! Thx a lot again! :slight_smile:


Plus, I see CRON is not working on AWSTATS :frowning: hmmm… any ideas?..


Ahh, it’s OK, I’ve found a mistake in my CRON (line splitting) and now everything works!

Thx! :slight_smile:


Hello all, I have also managed to get through the installation, but I am having the same problem, specifically: is not being created at all. When I run the command I get the following:

Launch update process : “/home/khalidsattar/awstats/” -update -configdir=
Build main page: “/home/khalidsattar/awstats/” -staticlinks -output
Error: Couldn’t open log file “/home/khalidsattar/” for writing : No such file or directory.

This is all very new to me, and I have no experience with perl or even working from the command prompt like this, but I really need to get this to work, so any help would be appreciated.

khalid sattar
new to dreamhost



I have installed AWstats successfully…

But i am stuck in inporting old records… I have configured my account to keep 180 days of log data…

i have used the bellow, Shell script to try to import old logs,

and run in in shell to update…

script runs with one problem,

=/home/me/logs/ permission denied…

how to solve it… ??

i want to import my log data to AWstats


Thinking => BrainPain


Uh, you can’t write to


so this means you must use a different file.

:cool: [color=#6600CC]Atropos[/color] |