Newbie please help


#1

Hi all, im hopelessly lost trying to navigate my way through setting up a website. Its all a whole new language to me. I have my domains ( 3 in total) and my hosting sorted, and am playing around with the one click installs as a simple starting point… but already hitting problems.

Im a quick learner, but have zero website experience.
I need urgently to use my site for image ftp loading and unloading,
and i have installed both Zenphoto and Gallery on 2 of my sites to see if they will work for what i need.

Im on a Mac btw, and Gallery has a handy iphoto plug in which will make image exporting faster and more direct, (although im still not sure if i can upload from there to my 3rd party selling tool app).

I will be using my site for commercial purposes, but for now it will just be a place to view and store images, before uploading them.
I dont want to be restricted by image size or quantity, as with most online FTP sites seem to be.

I also noticed net2ftp which might be an option too…

Can anyone please help me work out what i need???

I would much rather set up a site i can "grow into"
with too many features available, than something i have to be changing the software of every week , if that makes sense…??

Thanks in advance for those that can assist me…

Cathy from Australia


#2

I have a Mac and use Gallery with my iPhoto plugin. It works great.

It sounds like your ultimate goal is to import images into your 3rd party selling tool, correct? If so, then what tools does the 3rd party application provide for adding/importing images?

If you’re looking for a place to view and store images, then they’re already uploaded for you to view and store. I really like Gallery, as you can password protect your albums if you don’t want others checking out your images. But once you’ve uploaded images to Zenphoto or Gallery, or any other viewing site, your third party application will most likely be limited to pulling an image by a URL and hopefully has that option. Your image will be at something like:
http://www.example.com/d/albumname/image.jpg

-Scott


#3

Scott, thank for replying im going crazy trying to work out what i need.

I like the look of gallery also, but i got stuck on the install.

I can upload to my 3rd party app using “my FTP server” or “my webdav server”

and i fill in the image path .

But first to install Gallery. To authenticate i have to copy a txt file to my gallery directory… i have no idea where this is !!!

Any help to get me further along would be greatly appreciated.

regards, Cathy


#4

I’m still not sure how your app will grab data. Maybe it makes an FTP connection to your server and you have to provide the path to your data. Gallery has a WebDAV plugin which I’ve not tried. Maybe that will be easier.

I’ve grown accustomed to the login.txt file. I click Download and it ends up in my Downloads folder. Then I upload it to the directory where I installed Gallery. It’s the same directory that contains config.php, modules, themes, and so on.

-Scott


#5

THanks for your reply Scott, you have been a big help.
I think Gallery will work, and i have worked out how to install the txt file, but i am getting an error message…Error

SQL query:

53646d029ff406bc45956d2861e29b19

MySQL said: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘53646d029ff406bc45956d2861e29b19’ at line 1

Do i have to change either of these settings…
" Character set of the file" ( its currently “utf8”)
or “format of imported file” the “SQL” button is ticked and the “SQL compatibility mode” is set to “NONE”

I am on a MAC OX 10.5.6

I have messaged Gallery help also.

thanks Cathy


#6

At what point are you getting this error? During the install? The email you received from the Installer Robot should tell you the steps and data to fill in to complete the process.

-Scott


#7

At step 1, and im doing all they ask as far as i know, with my basic website knowledge.
downloading txt file, (which matched same on page) into the import box of phpmyadmin… in the database i have made for the gallery .

pressing go… and that error comes up.

i might try a cache clear and a re- boot and try this again to see if its the same result…


#8

After the screen with the text file, did you click Continue and have it tell you that Authentication was successful? I don’t recall what the very next step is, though.

-Scott