New user - ftp problem


#1

I set up a new user for ftp purposes earlier tonight. I may simply have gotten the whole thing backwards but the original/root/main username for my DreamHost account works fine through the Cyberduck ftp client on Mac OS X.

So… my domain at DreamHost is hofteigur.net. I set up a new user, gurpsfiles, and I’d have expected to see the path hofteigur.net/gurpsfiles become active. Home directory is listed as /home/gurpsfiles but I’m at loss at how to enter this info into my client to make it work right. Does my main user need to create the directory?

With path set as home/gurpsfiles in the client I get an error listing no such directory when logging on with my ftp client. It then goes on to show me a root with the folders Maildir and logs. If I ftp upload a file to that root I’ve no idea how to get an url for it…

Maybe I’m just being very stupid but I’d really appreciate being set in the right direction on this.


#2

[quote]I’d have expected to see the path hofteigur.net/gurpsfiles become active.
Does my main user need to create the directory?

[/quote]

Though DH docs say “You will see a folder on our server called yourdomain.com. This is where you must send your web files in order for them to be seen at your web address.” sometimes the DH system creates it, sometimes it doesn’t… or at least not before the user has given up waiting. So you may need to create it yourself.


#3

Thanks. I’ve been able to reroute the path so it has become active. However, I still can’t seem to figure out what path I should direct my ftp client to.


#4

Your FTP logon will normally put you in your user’s home dir. Create a sub-dir ‘yourdomain.com’. Put your web site files there.

In panel Domains, Manage Domains, [edit], if not ‘Currently Fully Hosted’, select this. Set ‘FTP user / CGI-runs-as user:’ to your user. If you changed anything, ignore the message ‘Your changes should take effect within 5-10 minutes’, wait anything up to a few hours, and then (DNS permitting) you should see your web files at www.yourdomain.com.


#5

Just to make sure we’re on the same page, because I am by now thouroughly confused. I thought I could handle most simple computer issues given a bit of directions, but apparantly that is not so…

Anyways, what I’m trying to do is set up a new user that does not have general access. He has a limited access to ftp so that he (them that get the username and pwd) can upload files that can then be accessed universally on the www. As it is I can see the index of the url I thought the files would appear at (hofteigur.net/gurpsfiles).

I’m fine with setting up a subdomain for it if that means it will work. But if that isn’t the issue I just as well not.

My problem is with getting ftp access. I’m using a ftp client which I can’t seem to get access with (works fine for the main user access) and I think it’s possibly because I’m directing it to the wrong path.

Now, I’ve only set up a new user but not set up any form of subdomain. I have remapped the sub-directory gurpsfiles however.

Maybe I’m just reading this all the wrong way. Thanks very much for your patience and advice so far.

Edit: I’ve probably done this wrong or something. I’ve deleted this user (again!) and I’m going to try to set up a new user, with his own subdomain and see if that works. Still, pretty frustrating. I did search for help regarding this, but a step by step guide might be nice…


#6

[quote]I think it’s possibly because I’m directing it to the wrong path.

[/quote]

Try following the instructions I gave, not directing it to any path. The server puts the FTP session in the user’s home directory.


#7

That might do the trick. I’ll try making a new user later and doing this. Otherwise I’ll set up a subdomain as well.

Thanks a lot for your assistance.


#8

Indeed. I deleted the “old” user, set up a new one and pointing the ftp client there via melrose, and not my own domain, with no path defined works fine.

I set up a sub-domain for that user and when it gets up and running I’m hoping to see web access work as well. Whew, this was a painful brickheadbanging…


#9

Hofteigur,

I wonder if you have figured how to get the URL for new ftp user. I’m now in the same boat and can’t figure it out.

Anyone?


#10

I’m sorry, but somehow this got fixed. I’m darned if I can remember exactly how, but when I have the time I will try and look into the correspondance regarding this, along with the setup that works. I’ll post any findings on this thread if I can turn something up.


#11

Hofteigur,

Thanks for the offer. However, I follow these instructions:
EX: New ftp user : happydog. Within happydog home directory, you create a folder called “happycat”. Within this folder you have a filename “happymouse.pdf”

In the Remap Sub-Dir section select the www.yourdomain.com/happydog. Hit continue.
Select /home/happydog from the left drop-down listbox. Then type in the “happycat” for folder from the right textbox. Then Hit Continue.

That’s it.

To access the happymouse file. You use the URL as followed:

http://www.yourdomain.com/happydog/happymouse.pdf