New uploaded images won't show after server move


#1

Hi,

Two days ago Dreamhost moved my sites to a new server and new images I upload are not showing up. New images uploaded to my static sites show up just fine, but don’t on my Wordpress blog. I am running Wordpress Version 3.0.1 on a custom install, not a one-click install.

I usually upload all my images with an FTP (I use WinSCP) and store them all in a specific subfolder such as http://www.myblog.com/my-imgs/image1.jpg I don’t use the primary WP image directory for images very often.

This has worked just fine since starting my blog quite a few months ago, but now that they’ve moved my blog to a new server, every image I uploaded now does not show — if I try to access the image alone in that folder from my browser, I get a “Not Found” or “Page not found” error, while I can access the old images through the browser just fine in the very same directories.

I’ve also double checked the file permissions of the old and new images and they are identical.

Is there some setting I should change to make it work. Again, all the old images in my image folder and subdirectories show up, but newly uploaded images I can’t get any access to.

Thank you.


#2

Go to the WordPress admin panel for Settings -> Media. The path should be /home/USER/DOMAIN/my-imgs. Right now I’m guessing it looks like /home/.SOMETHING/USER/DOMAIN/my-imgs, so get rid of the .SOMETHING in the path.


#3

Okay, I got it to work. My problem was that when it was all moved to the new server, the DNS pointers with my URL registrar (which was different than Dreamhost) had not been updated, so I had to go do that. It had been accessing the old server for everything. That’s why when I uploaded images to the new server, it couldn’t find them. Now with the DNS pointers changed everything is working dandy! Yay!