New subversion support


#1

I’ve just created a new subversion repository named “sources” with the new subversion control panel in goodies. That part seems to have worked (i see files in ~/svn/sources), but the repository doesn’t seem completely setup, or likely I’m just not doing something right. Here are a few things that I’m trying and that are not working:

first trying to import from a dump file gives me this error:

[doheny]$ svnadmin load sources < dumpfile
svn: No such revision 0

I have also tried a checkout onto my home computer and I get this error:

imac:~/Desktop/test2 jessegrosjean$ svn checkout --username myuser --password mypass http://subversion.hogbaysoftware.com/sources/
subversion/libsvn_ra_dav/util.c:780: (apr_err=175002)
svn: PROPFIND request failed on '/svn’
subversion/libsvn_ra_dav/util.c:295: (apr_err=175002)
svn: PROPFIND of ‘/svn’: 500 Internal Server Error (http://subversion.hogbaysoftware.com)

Looking at the repository that’s been created I don’t see these two files that I do see created when I create a new repository on my own computer:

db/revprops/0
db/revs/0

If I create an empty repository on my own computer and then copy these two files from it to the repository that’s been created by dreamhosts control panel then I’m able to load my dumpfile into the repository and I can checkout. But something still seems odd because I get errors when I try to commit. Here’s what my checkout and commit looks like:

imac:~/Desktop/test2 jessegrosjean$ svn checkout --username myuser --password mypass http://subversion.hogbaysoftware.com/sources/Blocks/trunk Blocks
A Blocks/version.plist
A Blocks/License.txt
A …

then I make change to a file, and try to commit

imac:~/Desktop/test2/Blocks jessegrosjean$ svn commit -m ""
subversion/libsvn_client/commit.c:832: (apr_err=13)
svn: Commit failed (details follow):
subversion/libsvn_ra_dav/util.c:368: (apr_err=13)
svn: Can’t create directory ‘/home/jgrosjean/svn/sources/db/transactions/199-1.txn’: Permission denied

Can someone tell me what I’m doing wrong and how to get this working? Thanks.

Jesse


#2

I’m also in the same position, I created the repository through the the web panel but it wasn’t properly or fully setup.

When I logged through SSH and did a “ps -eaf” I saw that the “svnadmin create --fs-type fs /path/to/repos” command was still running, it essentially had been since I asked the web panel to create the repository, but never finished.

The rest of the errors I got are similar to what you got.

I tried running the command manually, and they never seem to return. So I don’t think that SVN has been setup properly yet, perhaps we jumped the gun too quickly??

Regards


#3

I have had the same problem. The issue I have figured out is related to http://subversion.tigris.org/faq.html#freebsd-hang

if you run the svnadmin command locally with strace like:

strace svnadmin create --fs-type fsfs /home/cotton/svn/willnotwork

the very last lines are:

open("/dev/random", O_RDONLY) = 3
read(3,

You will see the last line is that it is trying to read from /dev/random and hangs there.

I’m not sure what we can do to get this fixed, and it might just be related to certain hosts where the entropy is not high enough. I have logged a support issue about it.

– Cotton


#4

Ahh ok, well hopefully they’ll fix this problem. But, in the meanwhile, I continued to play with the “svnadmin create” command after I felt that it had gotten stuck sufficiently, instead of killing it with "kill -9 ", I just did "kill " and strangely enough the necessary files were there in the respository directory.

I could then go ahead and use TortoiseSVN on my XP machine to access my newly created repository and do all the stuff I wanted to to with no problems.

Very strange!

Regards


#5

I got email back from the Tech Support saying they had fixed the randomness issue. I had to delete all the files in my ~/svn/ directory.

But now creating the respository works, and I just did my first commit! woohoo!

Cotton