New PHP.ini


#1

I recently followed the directions on how to make a new php.ini so I could allow larger files to be uploaded through my w2box repository. When I made the changes to the .htaccess,;

Options +ExecCGI
AddHandler php-cgi .php .html
Action php-cgi /cgi-bin/php.cgi

I got a 500 Error, so I checked the logs:

Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

I did not get this error before I went through with the custom php.ini. The only think I changed was the max upload. What would cause this error?

Thanks

Ryan


#2

I run this config and haven’t gotten a 500. How about showing us your complete .htaccess file with any sensitive information X’d out.

And how about a link to the erroring page?

In the mean time, add a blank line at the end just to be sure.

-Scott


#3

Ok, here is my .htaccess

Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi
Options -Indexes

And here is a link:

http://codpub.com/stuff/

The blank line 5 at the end of my htaccess file is already there.

I really need this work, all help is appreciated!

Thanks
Ryan


#4

The same thing also happens at http://rep.codpub.com

Here is the htaccess file:

Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{QUERY_STRING} ^$
RewriteRule ^(.*)$ index.php?d=$1&BAD_HOSTING=%{HTTP:Authorization} [L]

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{QUERY_STRING} ^(.+)$
RewriteRule ^(.*)$ index.php?%1&d=$1&BAD_HOSTING=%{HTTP:Authorization} [L]

RewriteCond %{QUERY_STRING} ^(.*)$
RewriteRule (.+).php $1.php?%1&BAD_HOSTING=%{HTTP:Authorization}

Thanks,

Ryan