New CPU usage limit - monitoring usage



With regards to the below, can anyone tell me how one can access the CPU resource stats for a domain whether it is on an evaluation server or not? I’ve got a user with ‘Enable user resource statistics’ ticked yet is Not Found.



We measure server resource consumption in CPU minutes. This number indicates how much time a processor spends working for your username. All shared hosting customers should use less than 30-40 cpu minutes per day for all their users on their account.

If you see a number referenced as cpu seconds, simply divide by 60 to get cpu minutes.

If you are presently on an evaluation server you can check CPU usage by downloading the file ~/logs/resources/*.sa.analyzed.0 . You should also be receiving daily resource reports to your primary contact email address. You can also view and download these stats files through the stats url of any of your domains (E.G. )


I have the exact same issue, neither of my domains for my user show anything under, stats/ shows regular stats, but nothing under resources.

Maybe it takes a couple more days then they said for it to show?


Before I got a 404, now I get a 403 (as of Friday)


[quote]Before I got a 404, now I get a 403 (as of Friday)


Still 404 here FWIW.


Yeah I still get a 404, weird.


You can find them by logging in via FTP and looking in the logs folder. You’ll see a resources folder in there with all the data.

I’m not sure why the web view isn’t working however.

bryan | website


The web access is broken, but in FTP there is a “resources” subdirectory that has a Perl script and some data files. I have two days of data files so far, and there are two types:
“itemized” appears to be a per-instance report, like so:

username 0.16 cpu 1388k mem 0 io ContactUs.plThen apparently the script is used to create the “analysized” files, that look like:

[code]Process CPU seconds user machine count average 1.6300 1.667% 0.007% 11 0.148

Total: 97.7700 100.000% 0.407% 794
Average per day: 97.7700 1 days
CPU percentage assumes 24000 cpu seconds per day total.[/code]

:cool: Perl / MySQL / HTML CSS


[quote]The web access is broken,


Ah. Did I miss the DH annoucement of this?

[quote]but in FTP there is a “resources” subdirectory


Subdirectory of what? I cannot see it anywhere here. I see only logs/, Maildir/ and /.



I checked mine, I found the “resources” directory in the main directory. where it lists your domains/logs/maildir.


I do not think the viewer works but the resource stats are working fine, although they tend to take x number of days to get working…

Check your /home/username/logs/resources directory you can run the perl program or display the files to see your usage…

Wordpress Gallery2 Integration Community ->


I havent gotten any announcements either about the URL not working either.

In my ~/logs directory there is a subdirectory named ‘resources’, user-owned by me and group-owned by ‘root’ and permissions set to 700. Strangely enough, there is a symbolic link in this directory that points to the very same directory.

In the ~/logs/domain/service_id/html directory, where the statistics web pages are kept, is a symbolic link named ‘resources’ which links to the ~/logs/resources directory mentioned above. Since they have aliased ‘/stats’ to the ‘html’ directory, one would expect the web server to access the usage reports at the URI ‘/stats/resources/’

I am getting the 403 Forbidden error using the URL they said to use because of the 700 permissions set on the ~/logs/resources directory. Since I am the owner, I can change the permissions to grant public/world read and execute permission.

Since there is no directory index page, all I get is the generated directory listing like so: Parent Directory 08-Jul-2005 07:48 - resources/ 09-Jul-2005 07:48 - 28-Jun-2005 22:06 2k 09-Jul-2005 07:48 3k 08-Jul-2005 07:48 3k 09-Jul-2005 07:48 41k 08-Jul-2005 07:48 48kSo, permissions on the ~/logs/resources directory are wrong and there is no fancy HTML generated.

:cool: Perl / MySQL / HTML+CSS


Yeah, just looked, mine isnt in logs/, but in main dir under resources/



I enabled mine when the announcement came out a few days ago, but there is no resources directory in the main directory, the logs directory, or the individual domain directories.

Where else should I look?


I wrote a little perl script to give me a graph. :slight_smile:

I don’t really know Perl though, so it’s probably no good… and you need to mess with permissions and .htaccess files to get it going.


Looks like the directory may have moved.

Support told me:
They screwed up the permissions in the configuration - I can make it
viewable manually for you if necessary but it would probably be best just
to wait until they push out the correction to the live servers (I am not
sure if the permissions I would set are what they want).