New account, no default A record


#1

I just got a new DH hosting account yesterday; my domain is not accessible yet.

I know it takes a while for DNS info to propagate, but on my DH panel DNS page, the list of “Non-editable DreamHost DNS records” for my site includes the 3 NS records, but no default A record.

Is that normal? Despite DNS propagation delays preventing me from initially contacting my host from elsewhere on the net, shouldn’t the default A record have been created immediately, and shouldn’t I be able to see it on the panel?

Also, I can’t ping my domain name from within my DH shell account, does that make sense?


#2

You only get an A record if you’ve set up some type of service, be it email or website. Have you added any email accounts or websites?


#3

Yes, it has an associated fully hosted new domain purchased from DH. The appropriate subfolder of my home folder was created. Is there something else I need to do to set up a website (other than populating the subfolder with html, etc. files)?

Only non-default thing I did was enable shell/ssh and disable ftp.


#4

If you created a Fully Hosted domain, then your DNS entries should have been added. If they’re still not there, go back into Manage Domains and click Edit for that domain. Go into the Fully Hosted section, don’t change anything, but click the Update button for your Fully Hosted settings. That forces a refresh of the system. If that still doesn’t add DNS records, either:

  1. Delete your Fully Hosted domain and try again
  2. Submit a support ticket

#5

Thanks for your help. The record was never created; I contacted support and they fixed the problem.