Need help with UNIX groups/permissions for FTP (yes, I read the wiki)


#1

So I know I’ve done this before, but it’s been a while, and I’m currently stuck.

I have multiple domains. I need FTP access to a new account that only sees a particular domain’s files.

I have read the wiki instructions at http://wiki.dreamhost.com/Unix_Groups on how to create groups and set this up.

I successfully completed steps 1-4. I am stuck on Step 5, where I SSH to the server. (If I recall, I actually used to do this through the old DreamHost WebFTP.) I downloaded WinSCP. But I can’t for life of me get any group but my default one to show up under permissions. I’m connecting via SFTP with SCP fallback. Is it just that the server hasn’t replicated (it’s been 4 hours).

I’m ftping into my root directory - ftp.elisehudson.com where I see all my domains listed in the file structure. I know there is a way to ftp into the server, and I’m on danelectro. I tried logging into ftp.danelectro.dreamhost.com to no avail. The domain to be “segregated” is tnprogressivenetwork.org.

I know I’m missing something. Or misunderstanding something. Please help! Thanks so much.[hr]
FYI - the post added http to my ftp sites after I posted. They should read ftp://ftp.elisehudson.com and ftp://ftp.danelectro.dreamhost.com. Thanks.


#2

Basically, you can’t make work what you are trying to do. See this: http://wiki.dreamhost.com/Users_Overview

See also http://wiki.dreamhost.com/One_User_Per_Domain_Policy

But you can also find in the wiki where it says this can be done: http://wiki.dreamhost.com/Sharing_Domain_Files_with_Multiple_Users

Also if you are attempting to try anyway (per the last link above) note that “Enhanced Security” can not be checked on the domain. Click “learn more” near that option when you edit any FTP/Shell user in the panel.[hr]

for the second one: ftp://danelectro.dreamhost.com should work.


#3

Seems like I used to be able to assign specific permissions through the WebFTP panel back in the day, but maybe I’m delusional since it would still have been UNIX. shrug Thanks so much for the information and help. I’ve got it figured out from here. Thanks!