Need Help Resetting PHP or Server Settings


#1

Hi, I have a client running WordPress. He had some WordPress gurus do some work for him and afterwards, file permissions for WP were changed. New installations of WP won’t work now until you change the permissions on wp-config.php from 640 to 644 (readable by world). A new installation of WP has the permissions on wp-config.php set to 640 but his entire installation pukes unless it’s 644.

Now I’m now permissions guru but I manage a number of clients on Dreamhost accounts and the install of a WP blog always works. After these WP people screwed with his account, his installations no longer work out of the box and you have to alter the permissions as I mentioned.

I’m concerned they may have had access to his entire dreamhost account and made changes to core server settings that would have created this issue.

I’m wondering if it’s possible to set his account back to default… whatever that means. I don’t know enough about everything that’s entailed to even know what to ask or where to start. I suspected they may have changed PHP settings but again I don’t know how that relates to UNIX file permissions. All I know is that they changed file permissions and resetting permissions to the standards breaks his site and any subsequent installation of WP under his dreamhost account.

Anyway, any help you can provide I’d appreciate it.


#2

I have an update to this situation. This problem started when the client’s account (both files and database) were moved to a private server. I suspect that in that move, the Apapche file owner was changed to something other than the account name.

Normally this probably isn’t an issue but with WordPress, the core update and plug-in update functions need to be able to write to the file system and if they are using a file owner other than the one Apache is using, WordPress continually prompts you to supply the information yourself. It’s an irritation to say the least.

You can read more about this situation here: http://www.chrisabernethy.com/why-wordpress-asks-connection-info/

From that article: “Many hosting companies will run your apache instance using your user account, and all of your files will be owned by the same account. In those cases, you will probably not have the issue described here.”

So I’m guessing that when this client’s account was set up for the private server, his Apache instance got a new file owner. This actually broke the site because now the permissions were screwed up and someone had to set the permissions to a less secure state just to get a web browser to read them.

Hopefully this added information helps. My question is how can I get the Apache file owner set BACK to the account name so WordPress is again happy with the permissions it was designed to use?


#3

Almost sounds like your consultant might have set your domain to run PHP through mod_php. Set that back to FastCGI in the Manage Domains section of the Panel and see if that fixes it?


#4

Actually the problem occurred BEFORE the consultant went and changed file permissions. All he did was bandage the real issue. But FWIW, here’s what the domain is configured for on the “Manage Domains” screen, Web Options section.

PHP mode: PHP 5 FastCGI
Extra web security: checked (yes)
PHP XCache Support: unchecked (no)
Passenger: unchecked (no)

These have never been changed since the account was first created.

I’m 90% certain this is the Apache file owner issue described in the article I included in my last post, I just have no clue how to verify that and then change it back if that’s the case.