Mysql


#1

Just wondering, but when i go into phpMyAdmin to view my databases it says I have No Privileges. A bit strange as I am the administrator. I would have thought I would have had full Privileges. Does not seem to be anywhere to alter this. Have been to web panel and it states that I have full access??

Does this stop me from accessing all features in it? just wondered.

Had to amend initial post, my god this is driving me nuts settings this up.

Added:
Error message on phpMyAdmin states:

The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results.

Kev King


#2

What privileges do you have set when you check via the MySQL management page and then clicking on a database user under the heading ‘Users with access’.

At what point does phpMyAdmin give you that message? Is it when you log in? If it is when you are trying to create a database from the phpMyAdmin home page then of course no-one can do that.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK! :@

Act on my advice at your own risk!


#3

Thankyou for the reply norm1037

1: I only have one user, thats me, i only started setting up yesterday. And all boxs are ticked.

2: Yes its when I first log in. I currently have 3 db’s and they all show the same, no priveleges in red type and that error message at the bottom of the page.

I did make a mistake on my first go, so thought I would delete the DB, unknowing that it is not totally deleted, and start a fresh. I would not think that that would make a difference though. I still have access to all 3 but cant seem to do anything with them, argh.


#4

I would be inclined to contact support in that case and see if there is a problem on the server.
I have never seen that error message before.
Have you tried creating another database and user/password combination perhaps even with a new mysql host? You have unlimited databases/users with DreamHost so you can always experiment and delete later.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK! :@

Act on my advice at your own risk!


#5

There is no problem, it’s just a standard error message in phpMyAdmin.

You create databases via your Panel, not with phpMyAdmin :wink:

Maximum Cash Discount on any plan with MAXCASH


#6

Because of the error message in phpMyAdmin I was also wondering if we could change the charset of a database without damaging it. My databases have a combination of utf8_general_ci, utf8_unicode_ci, and latin1_swedish_ci charsets. It seems the charset is simply the default of whatever environment I used to create the databases.

A quick Google returned this nice page with links to many others. I haven’t gone through the operation of converting to urf8 yet but I would like to do so in the near future just to keep things consistent. If someone else goes through this I’d be interested in the method used and the results, and I think many others would value the info as well.