Mysql Stumper

apps

#1

For another MT installation, I am starting all over again with another host I’m responsible for on Dreamhost, and I’m getting stuck at the MySql stuff. Even though the database is a couple of weeks old, when I try to connect to it directly or try to load mt-check.cgi, I get:

ERROR 2005: Unknown MySQL Server Host ‘mysql.talk.lii.org’ (1)

I went in to the user configuration and modified “Edit the hosts from which the user can access…” to add *.talk.lii.org (This is for a site that is a subdomain to begin with on Dreamhost, so I thought maybe it would appreciate a little guidance.) I waited. No go.

I set up a whole new host (sqlhost.talk.lii.org), database, and user, waited well over an hour, and tried again.

ERROR 2005: Unknown MySQL Server Host ‘sqlhost.talk.lii.org’ (1)

And just in case I was being impatient, I tried again with the host I created weeks ago,

mysql -h mysql.talk.lii.org -u [username] -p [database]

and still get:

Unknown MySQL Server Host ‘mysql.talk.lii.org

Thoughts? This host is on a different DH machine than the one I got going, but it passed mt-check.cgi so I doubt that’s an issue.


#2

Have you tried mysql.lii.org ?


#3

We’re not authoritative for lii.org, and you (apparently, although I didn’t check) don’t have DNS service enabled. This is a good thing, but will prevent DNS records from getting added.

What I usually recommend folks do in a situation like this is to add a blah.dreamhost.com subdomain (like lii.dreamhost.com). This subdomain doesn’t have to have web or mail service enabled - just DNS service. Then add the MySQL hostname to this subdomain (so you’d have something like ‘mysql.lii.dreamhost.com’.

Alternately, you could have the organization that does DNS for lii.org delegate talk.lii.org to our nameservers (while retaining control of the zone itself), and you could create “talk.lii.org” with a DNS service (we’d have to do some voodoo to get this to work properly, though). A little tidier, but way more of a PITA.


#4

That works! Great! Thanks!