Mysql information


#1

i downloaded this program that helps you organize mysql queries, but i think i need some help with the open connection information.

i have been using the same information that i use to connect to the phpmyadmin panel, but that didn’t work. i also tried using ivan(my dreamhost machine).dreamhost.com and using the port listed on the phpmyadmin mainscreen but nothing worked.

the program asks for two sets of information that i assumed to be the same:

source connection parameter:
hostname…
port…
username…
password…

target connection parameter:
hostname…
port…
username…
password…

i was wondering if anyone knew if the hostname is something different than the one that you create (mysql.mydomain.com) and machine.dreamhost.com. also if there is a set port that i should be using.

thank you.


#2

First, yes, the hostname is machine.dreamhost.com, the one you created in DH panel.

ok here is what I’ve experienced before. When I upload my php files to the web server and connect to database server from there, it works fine.

When I tried to connec to MySQL server locally from my machine, it says the access is denied.

I guess it allows you to connect to MySQL server only from the particular web server and block the access from outside world. I believe this is for security issues.

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#3

Well, it could be, but that is not necessarily the case. In fact in the sense that “machine.dreamhost.com” is usually taken to refer to your webserver , as in “genki.dreamhost.com”(not your MySQL host), it is generaly not what you will use. the hostname is what you defined as the hostname for the database when you created the database in the control panel. By default, the DH panel suggests “mysql.yourdomain.tld” for the host, and many leave it that way, though you can make it be “mydatastore.yourdomian.tld” or something else if you so desire at database creation time.

This is true, by default, and it is for security reasons, but this does not mean you cannot connect to your database from your home machine, or another machine outside of Dreamhost.

In order to do this you need to modify the permission of the database user you wish to allow to access the database remotely. From the Control Panel–> Goodies --> Manage MySQL screen, click the linked user name for a given database. This will bring up a configuration screen where you can modify that user’s permissions for the database and add additional “hosts” from which that user may access the database. These hosts can be in the form of another domain, or an IP address. Setting these appropriately will allow that user to access the database from that location in addition to from within Dreamhost. :wink:

–rlparker


#4

If the program you downloaded is trying to connect to your database from your personal machine, you will need to make a change in the user permissions for the database user to allow for the “remote” connection. Please see my previous post in this thread for precise instructions on how to do that.

You should be using the “mysql.yourdomain.tld” for your hostname, not “machine.dreamhost.com”, which is your webserver, not your MySQL host. :wink:

–rlparker


#5

thanks, it worked.


#6

You’re welcome, and I’m glad you got it sorted out! :slight_smile:

–rlparker