Mysql import


#1

Hello there. i’m trying to import a mysql database via phpmyadmin and i recieve an error.

“Fatal error: Allowed memory size of 52428800 bytes exhausted (tried to allocate 18924327 bytes) in /usr/local/dh/web/phpmyadmin/libraries/read_dump.lib.php on line 91”

The file itself is around 600k compressed.

Question is, am i able to go through ssh get it done? if so could you point me to a tutorial.

Thanks
Josh


#2

Any help would be appreciated.


#3

You should be able to use phpmyadmin to import any file under 7mb, so there may be an error somwehre in your file, or with the server. But this Wiki Article should help you out. It covers phpmyadmin as well as using shell.

-Matttail


#4

Thanks much, I have tried phpmyadmin, with no luck. I tried through SSH and had no luck either. My ssh connection was killed while in the process of importing. I sent a support ticket and maybe they’ll do it for me? Is there a way i could do it in parts?


#5

Use mysqldump for larger mysql imports/exports. That works.
PHPMyAdmin is rather limited in import file size.


#6

The wonderful Dreamhost support imported it for me. :slight_smile:
Thank you for the replies though.

Josh