mySQL import access denied

I have one database I am moving to a new user (new domain)
I exported my db to a text file dump.sql
I created a new mySql DB with the same user name and PW but I keep getting
#1044 Access denied when I try the command line option or through phpMyAdmin. This is a small db. I know very little about phpMyAdmin.
It seems that the original dumped file may want to only be imported back into a db with the same name and url??
Please help.

Did you set up the new database server then create the database and user in the Control Panel?

If so, try looking at the dump file, it is plain text. There may be some lines about dropping and creating a database that you should delete.

Accessed deined means that for somereason it’s not accecpting the user name and or passowrd taht you are feeding it. Double chck for spelling erros and capItilZation problems. If not you can allways create an additional user for the datbase and connect with that one.

You can also double check your user name and password by logging into phpmyadmin, that would be the same combo that you should be using for the import.


Yes. I think what you mean by setting up a server is something like hostname: I did that.
So now I have an empty mysql database. I set this up before the new domainname server may have pointed at DH, but I was able to access the empty db. I deleted the new db and I set up another one, which I am waiting for to become live.

How does one get out of phpMyAdmin properly? I try to log out and it asks for my password again. I seem to be in a loop.

Thanks Mattail. I got this error after logging into phpMyAdmin. I then tried the command line.

Regarding logging out of phpMyAdmin properly, I do not know if it that is possible: some time ago I read, quite possibly in these forums, that the only way to exit phpMyAdmin is to end the loop by clicking cancel when prompted to re-authenticate–it is all a bit odd, I know.
All the best -

Solved. The backed up file had create database information in it. DH commented it out for me and imported my file. Good follow up from them.