MYsql error

apps

#1

I got this page am creating(dreamweaver Mx) using EasyPhp software and
the server Apache server is running but I cant seem to
connect to the database
am getting the error:
HTTP Error Code 404 File Not Found.
1)There is no testing server running on the server
machine.
2)The testing server specified for this site does not
map to the http://domain.com/
_mmServerScripts/MMHTTPDB.php URL. Verify that the URL
Prefix maps to the root of the
site.
yet this are the configurations of my connections
Connection Name: connect
MySQL Server: localhost (not sure if this is correct)
User Name: root
Password:
Database: database

what could be the problem?
please help


#2

Those error messages indicate a problem with either your Apache configuration, your MySQL configuration, your Dreamweaver mx configuration, or any combination of the above. It looks as though MySQL is not running.

There is no way I can tell what might be happening on your home system; every user’s home system is configured differently. The only thing I can suggest is that work back through your installations and configurations until you are sure you understand your setup, and that you have all your configuration settings made appropriately for your system.

Make sure you have both Apache and MySQL running, then try again. Work through your error messages one at a time. Good Luck!

–rlparker


#3

The Apache server is working right and has no problems but the myql connections that is the one bringing problems


#4

I understand. Are you sure that MySQL is running? If MySQL is not running on your system, all your attempts at connecting will fail, even if the “settings” are correct.

–rlparker


#5

its up and running just tested it.


#6

If you can navigate the web directories via apache, and can manipulate mysql directly via PHP, then the problem has to lie with your DreamWeaver mx settings. I’d focus my attention there, and possibly look for DreamWeaver specific help on Dreamweaver or Easyphp forums.

I don’t use Dreamweaver, or Easy PHP (I use xampp) so my knowledge of specifics required for your connection(s) is very limited.

–rlparker


#7

thanks I will do that.


#8

Hi nick0dera,

I had similar problems connecting to my mySQL database from DW8.

I noticed that you have localhost as your setting. Try changing this to mysql.mysite.com, where mysite.com is your DH site. You can get the exact name for the mysql hostname in the Control Panel under Goodies / Manage MySQL. It’s at the top of the page.

Also, I found that in order to permit DW to connect to your db, you have to add your IP address to the list of hosts that can connect to your database(s). Do this:
Still in Goodies / MySQL, at the bottom of the page you should see your existing database(s). Underneath “Users With Access”, click on the existing user’s name. Find the line: “From what hosts (computers) may “username” connect to these databases?” and enter the IP address of the computer running DWMX.

As long as your settings are correct you should now find that DWMX can connect to your mySQL database.

Hope this helps!

-sameer