MySQL DB for crawling for Wordpress

wordpress

#1

My Wordpress pages take forever to load. I have caching disabled for now because I’m making a lot of changes, but even with caching on, pages take at least two seconds to start loading in the admin section, and even longer for the frontend. It feels like I’m using dial-up!

Does anyone else have this problem?

If you have a solution to this, please let me know. Also, if you know of any settings or tweaks that improve MySQL performance, please let me know as well; I have had performance problems with other applications as well that are database-intensive.

Thanks!


Patrick
http://inmyholyopinion.com


#2

You might want to report it to support to check into the DB server. Another users’ queries could be killing you. You do have a lot of big images, I don’t know how badly that would really affect performance because it really does start displaying after a significant delay.

Wholly


#3

Hey Wholly, I’m glad you were able to observe the low speed as well, I wasn’t sure if maybe it was just me. I’ll open a support ticket and see what they say, meanwhile I was wondering if there is an easy way to find out from MySQL how many queries it ran for the current connection, and what the average speed of a query is. That way, I can find out if it really is MySQL that’s slowing down my applications, and which queries take the longest. Thanks!


Patrick
http://inmyholyopinion.com


#4

There’s not a “really easy” way, but the mysql admin tools available from mysql can give you a good idea of what’s going on with the box and if slow queries are causing the problems. You can learn a lot about the server through it (and it’s safe for the server).

The trick is to make sure your db user (in the DH control panel) has clearance to connect from your IP. (Select the user name when looking at the mysql config and you’ll see what I’m talking about).

Good luck!

Wholly


#5

I’m having issues with MySQL, too. It times out or fails to load completely. I’m also getting partial loading and errors telling me that “mysql_numrows(): supplied argument is not a valid MySQL result resource in /home/.isabelleblender…”

What’s funny is, even the official phpadmin site (unrelated to DH) is failing: http://www.phpmyadmin.net/home_page/index.php

Warning: fopen(./datas/rssfeeds/pma_newsfull.xml): failed to open stream: Permission denied in /home/groups/p/ph/phpmyadmin/htdocs/home_page/includes/lib_rss.inc.php on line 100

Warning: fputs(): supplied argument is not a valid stream resource in /home/groups/p/ph/phpmyadmin/htdocs/home_page/includes/lib_rss.inc.php on line 101

Warning: fclose(): supplied argument is not a valid stream resource in /home/groups/p/ph/phpmyadmin/htdocs/home_page/includes/lib_rss.inc.php on line 102

Warning: fopen(./datas/rssfeeds/pma_newsfull.xml): failed to open stream: Permission denied in /home/groups/p/ph/phpmyadmin/htdocs/home_page/includes/lib_rss.inc.php on line 106
Error reading RSS data

Weird, my MSSQL server is working fine! :slight_smile:
Seriously, I read on the DH status page that they had a RAID failure so it may be some time before all the data is stable again.


#6

my blog page has been loading extremely slow for the past 2 weeks ever since upgrading to 2.0.6. ive since upgraded through 2.0.7 and am now using 2.1. everything still loads extremely slow, even a clean install. ive talked to support and the server is ok. not sure what ill do, maybe go back to using 2.0.5.


#7

Wholly, thanks for the tip, I’m going to try out those tools; my last host didn’t allow remote MySQL connections, that’s why I never had a chance to look into this.

Everyone else who has DB problems, I’m going to post my findings and solutions here.

Defender, I think you are having problems with your Internet connection, that’s why a lot of sites are failing to load properly for you; if you’re having problems with unrelated sites, then it’s definitely not the MySQL server that’s giving you trouble.
As far as your application is concerned, I don’t think that’s a database problem either, based on the error messages that you posted. I think it’s actually a file permission problem. Use your FTP client or your SSH client to change the permission on the files in question to 755 and reload.


Patrick
http://inmyholyopinion.com


#8

I talked to support, and they moved my site to another HTTPD thread because there is another site that’s really busy on my server; the database server seems to be behaving normally. My site does load much faster, but they forgot to enable .htaccess (required for mod_rewrite) on the other HTTPD thread, so I can’t really test out the overall performance until that’s done.

Thanks Dreamhost support!

I’ll play around with it as soon as I can, and I’ll report here when I find out for sure what’s causing the problem.


Patrick
http://inmyholyopinion.com
http://patrick.salami.name


#9

Good to hear.

Wholly


#10

Solution:
Dreamhost support kindly moved me from snapple to pepsi, which resolved this problem, at least for now. I concluded that the database server was not responsible for the slow loading of my pages (although a lot of DB queries certainly don’t help performance).

It looks like httpd was the culprit here; after switching to another server the performance is fine (but not stellar).

I’ll keep an eye on this to see how things develop over time. I’m sure whatever problems might arise, support will take care of immediately. Dreamhost (Justin) has really come through for me today, and I really appreciate their excellent support; that was completely unexpected. I am putting a lot more steam behind the rewards program because of this.


Patrick
http://inmyholyopinion.com
http://patrick.salami.name