MySQL Databse Access


#1

Is it possible to access one’s MySQL Database from outside the server? For instance if I were to try to log into it by using “MySQL Query Browser”. My current host restricts it for security reasons… I was just wondering what DH’s policy is on that.


#2

Not only possible at DH, but it works well and is “officially” supported. From the Control Panel, under Goodies, MySQL, you can “edit” you database information to allow access from other IP addresses. Just go there, add the IP address of the computer you want to access the DB from, and DH will let you in!

–rlparker


#3

Wow…thats really… really… really… awesome. Signing up tommorrow!


#4

I must admit, I couldn’t find the IP address list when I went looking for it recently. It’s location in the panel is not immediately obvious (to me at least).

To possibly save you some time, here is the location;

Goodies -> mysql

Then click on the database name under the Users with Access column. In here you can add remove IP addresses or ranges uses wildcards.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#5

–I’m not the OP–

I’ve added the IP address that I want to access the DB from, but the Query Browser still won’t connect to the database server.

Any ideas?

-Matt


#6

What error are you getting?

–Matttail
art.googlies.net - personal website


#7

"Connection Error
Could not connect to MySQL instance at database.domain.com

Click the ‘Ping Host’ button to see if there is a network problem."

When i click Ping Host I get no response. Perhaps I’m not using the proper server hostname?

-Matt


#8

right, you should be connection to the host name you set up when you created the database. Log into the Panel > Goodies > Mange mysql. Find your database in the list and see what hostname is associated with it - use that. It will be something to the effect of mysql.yourdomain.com

–Matttail
art.googlies.net - personal website


#9

That’s what I’m using :-\

The same address as the phpMyAdmin address.

-Matt


#10

can you access phpmyadmin from your browser and log in?

–Matttail
art.googlies.net - personal website


#11

Yep, I’ve been using that method for about two months now. I’ve come to dislike writing queries in phpMyAdmin, though, and I want to use the Query Browser instead.

I’m using the same username/pw with phpMyAdmin as with the Query Browser, but nothing works.

Even a ping or traceroute to the database doesn’t work.

-Matt


#12

That indicates an error with your program’s set up. Unforunatly I’m not familiar with it though. I’d double check your settings and then see if there’s a forum for the program… perhaps they can help - enless someone else here has a sigguestion.

–Matttail
art.googlies.net - personal website


#13

I thought not being able to ping the server would indicate a network problem.

-Matt


#14

But if your computer is able to access phpmyadmin through your browser, it obviously is able to ping it. Here’s a thought, try this url instead:
http://www.example.com/dh_phpmyadmin/mysql.yourdomain.com/

You might also run a ping on your hostname from the command prompt of your comptuer and see what IP it returns, then plug that into your program. - It’s worth a try anyways…

–Matttail
art.googlies.net - personal website


#15

Are you sure you’ve added the correct IP?

You can check your external IP from a service like http://www.whatismyipaddress.com/ or http://www.whatsmyip.org/. Also be aware that you’re IP might change from time to time (depending on your ISP).


[color=#000000]DreamHost Promo Code[/color]: [color=#CC0000]Save $50[/color] with the promo code DREAMTEAM


#16

When you click on the MySQL user to set your IP you will see the IP you are coming from listed underneath the box, so enter that dotted quad.

Check that your program is trying to connect on the correct port of 3306.

It may be that ping is turned off so you cannot always go by no pinga.


Norm

Opinions are my own views and are not the views of DreamHost.
Any advice offered by me should be acted upon only at your own risk.


#17

I’ve added the exact IP address and nothing happens.
I then changed it to the IP address with the last two parameters being wildcards and that won’t work.

Port is 3306.

Hmm…

-Matt


#18

Try creating another test database at another hostname and see how you go. It may be a problem with one of the shared mysql servers. Arlene had to have a new hdd yesterday so perhaps another one is going the same way.


Norm

Opinions are my own views and are not the views of DreamHost.
Any advice offered by me should be acted upon only at your own risk.


#19

Hmm… I came home and it works fine here. Must be a problem with my work connection.

Thanks for the help, all.

-Matt


#20

Maybe they block certain ports at work. I know some companies tend to do that.

Glad you are up and running again.


Norm

Opinions are my own views and are not the views of DreamHost.
Any advice offered by me should be acted upon only at your own risk.