MySQL and pMachine


#1

Anyone running pMachine? I am attempting to set it up, but keep running across an error while trying to run the installation script. I get an error that the user does not have permission to use the database. According to pMachine tech support, I need to make sure the database user has access privileges for that databse. I then contacted DreamHost, and they told me that I needed to set up the database user to be able to access from my particular IP address. I have done so, yet still am encountering the error.

Any ideas on how ot get it up and running?

Thanks.


#2

First a clirafaction, are you trying to install Pmachine here, or on your home computer - and only acces the database on dreamhost?

Or are you just trying to make a normal installation here on dreamhost?

-Matttail


#3

Just trying to do a normal installation here on DreamHost.


#4

Ok, first off let’s make sure that you’ve created the MYSQL database properly.

That’s at Panel > Goodies > mysql

DB name is simple - anything unique, maybe like domain_pmachine

Next type in a host name, any dubdomain that you have [b[not[/b] used allready.

Then a user name and pass. Please note that these are both CaseSenSitiVe. (if you’re allready created a database and are not sure of your password, you can allways click to modify that and change it. You user name is displayed - make sure there’s no capitalizations you forgot about)

You can verify that the database is up and functioning properly by going to that host name you created. It will prompt for user/pass and then let you into phpmyadmin. If this works, your datbase is up and function properly and you typed in the user/pass correctly.

Next you have to set up Pmachine to access your database. Not only do you have to provide the correct user name and password, you’ve got to tell it the hostname of your database. A lot of times, by default a program will try and access :localhost but that’s no good here at DH. you’ll have to give it that subdomain that you entered when you created the database.

Once this has been accomplished, it should work.

You don’t need the IP address of your home computer in there either. (that’s under the manage link for your database) you’d set that up if you wanted a program on your computer to be able to directly access the mysql database at DH.

If you don’t get it working, let me know and I’ll look into my setup of Pmachine here at dreamhost and see if I can find specifically where and how I set up the database.

-Matttail


#5

The database is indeed up and functioning, since I can log into phpmyadmin (mysql.camanochapel.org). I followed the pMachine instructions, and modified the database variables in the config.php file (server address, username, password, and database name).

Regarding IP addresses, I have entered my IP address, as well as a complete wildcard address (%.%.%.%), so in theory I should be able to access the database from anywhere. But, if things are as you suggest, none of that should matter, anyway.

In any case, I am still unable to finish running the installation script…


#6

Hmm. I’ve got two pMachine sites and one Expression Engine site running fine on DH. I never even had to do any special tinkering with remote access IPs or anything. Look carefully that the config hostname matches the complete mysql hostname. Also, I might try and create a second user for the db and try that as well.

My pMachine sites run php-as-cgi. Do you have that option set on your ‘manage domains’ panel?

I’m stumped! Sorry.


#7

I double checked the config file, and everything is as it should be. I created a second user, and am encountering the same error.

You mentioned php-as-cgi set up in the ‘manage domains’ panel. I could not find that option anywhere. Could you be more specific as to the location?

Thanks.


#8

under domains >> manage >> edit the web settings for your domain >> select run php as cgi (or the other way, whichever you are looking to do


#9

Got it - thanks. Hopefully that will make it work.


#10

Well, don’t know what the problem was, but I finally got things running. I ended up creating a brand new database and user, and things went smoothly from the start. There must have been something weird with the first one I made.

Thanks for all the help!