My "successful" installer robot install isn't working


#1

Hello,
I’m in the process of switching from WordPress.com to self-hosting on Dream Host. I used Dream Host’s install robot yesterday and seem to be stuck in the middle of the process. I got a “successful install” email with a link to http://www.mydomain.com/wp-admin/import.php (and a couple others). When I clicked this link yesterday on my PC, at first I got a “page not found” message on my WordPress.com blog. When I tried it on my phone, I was able to get to the dashboard and set up my admin user. Today, I can get to the dashboard using my PC, but when I try to do anything (“import” “post” etc.) I get sent to the authorization page (username/password request). Sometimes I can get back to the dashboard with my username and password, but other times I get sent to the WordPress.com authorization page. (I think Einstein might have said, “Insanity is doing the same thing over and over again and expecting the same result,” had he lived in the digital age.)

I found this Wordpress forum post from a year ago but the suggested solutions got me no where. Do I just need to wait…maybe my DNS needs to propagate? (Not that I have any real idea of what that means.)

I’m a total newbie so speak slowly :slight_smile:

Thanks for your help!

P.S. I cleared all my browsing history and tried another browser, no luck.


#2

Normally, DNS doesn’t flip-flop like that. In simple terms what’s happening during “propagation” is the “news is spreading” to namesevers around the world that your domains traffic should no longer be sent to wordpress.com but should now go to dreamhost. Your phones nameserver got that news first, later your PC’s nameserver got the news.

Things that I can think of offhand that would account for the type of behavior that your describing are an error in your DNS setup, or possibly importing a database that had some hard coded links in it.

If you give use the actual domain name instead of a generic example we can tell you alot more.
[hr]
Actually, http://www.dreamhoststatus.com/2012/06/13/dns-server-problems/ could have been part of your problem. What’s going on with it today?


#3

Thank you LakeRat,

After about 24 hours of effort, I finally came across the solution: I had to delete the “www” from my url home options in my database as described here http://www.tamba2.org.uk/wordpress/site-url/.

Thank you again for your help!
Renee