My links don't work at my non-"www." site


#1

Hi,
My webiste shows up on both the http://www.domain.com/ and http://domain.com/, but the links in the navagation don’t work at the http://domain.com/. In my “manage domans”->“edit”->“How do you like the www in your URL?” I have “Both” chosen, and like I said, the site shows up at the non-www site, but when I press the links to “Press” “Contact” “Boutique” etc it just stays on the same index/home page.
Someone said it might be a DNS propagation issue, but I don’t think this is the case because I remember someone mentioning 6 months ago, while I was building the site, that they couldn’t navagate anywhere. I couldn’t understand why and had never heard anyone else say that so I brushed it off. Now I realize they probably left out the “www.”

Any help rectifying this would be much appreciated!
Thanks in advance :slight_smile:


#2

Personally, I don’t use the “both” setting. Either use “Add” or “Remove” “www.” and stick with the one format.

But if you want to keep “Both,” post the URL so we can take a look.

-Scott


#3

If I can’t get the non-www to work, I guess I will have to just choose one. Which seems to be the preferred option?

My site address is www.*****************.com

As you will see, the links on *****************.com are the ones I am having problems with. Is it something to do with coding, or a setting I need to change in my Dreamhost panel?

Thanks for the help, I appreciate the imput.


#4

I suspect the problem has something to do with URL paths in Flash. I’m not a Flash person, so I don’t know how those addresses are set. It looks like they all have the full URL of “http://www.EXAMPLE.com/” in them, rather than just a “/”.

If you want it to work right now, then set it to Add “www.” for your site. And then I recommend you look into the URL encoded into Flash and other parts of your site to address the issue mentioned above.

There’s a debate whether sites include “www.” I use them because that’s what everybody expects, but logically, we shouldn’t be using “www.” Here’s one site that explains why:
http://no-www.org/

-Scott