My index.php gets downloaded, not executed


#1

This has to be a very newbie question, sorry but I don’t have PHP experience and I am transferring a site from another server.

I just activated my Dreamhost account, tried to upload the code from the site and it didn’t work, so I deleted everything and started with just an index.php file.

It seems that though the control panel says PHP is enabled using FastCGI, php files, like index.php file, are not being interpreted, so the browser attempts a download.

Can you point me in the right direction? Thanks in advance,

Alex


#2

It looks as though you’ve copied over an .htaccess file from your previous host containing an AddHandler directive that’s specific to your previous host. I’ve deactivated this file for you by renaming it to “.htaccess.old”, and your index.php now appears to be working.


#3

Thank you very much for your support. I think that was the problem, it actually works.

Alex.