MX records not saving

I’m trying to set MX records so that I can use my gsuite account.
e.g., mail.mydomain.com

I have tried a variety of ways to adding MX records:

Depending on which way I do it, I have the option of entering a host, in addition to the MX server address and priority.

I am not able to leave host blank. It does show mydomain.com in grey. I can enter “mail” but I can’t put “@”.

For the MX server address, I am adding them per Google’s instructions:
e.g., ASPMX.L.GOOGLE.COM
I’ve tried both with and without the period at the end.

In all cases, the MX records show up in the list briefly, but after the DNS propagates and I refresh the page, the MX records are gone.

I’ve tried it 5 times now, and it is pretty frustrating. Any advice is appreciated.
Thanks.

Try removing the middleman (“mailchannels”) DH now use to see if that will switch off some form of automated background rewriting.

Panel → Mail → Anti-spam
Click Edit Filter next to mail domain
Click Edit Settings button
Click Change Filter Settings and Proceed to Disable Filtering