MX records gone, won't return


#1

Ugh. Email for my domain is completely down due to what appears to be a DH bug.

Went to my domain tonight to add an A record. Added it, didn’t think much of it. Later got an email error sending to my domain… very strange. So I tried to lookup the mx record for my domain from a remote system. Not found! Went to the panel and verified it was set for GMail (as it has been for the last 2+ years).

Checked my other domains… they show MX records in the DNS page.

Anyway, to cut to the chase: I cannot currently put an MX record on my domain. Gmail or custom, neither work. They just don’t show up.

So inbound email to my domain is currently broken. Support ticket filed, of course. Sigh.

Anyone run into this? Perhaps a workaround or other setting that will get around what appears to be a bug? I’ve tried switching to local hosting and back to gmail/custom. No luck there. Also tried refreshing DNS. No luck.


#2

It’s a bug, confirmed by support, and they can’t help me until the developers fix the bug. Domain transfer to GoDaddy happening right now. Bye bye forever DH.