MX Record Format


#1

I’m having trouble adding an MX record through the control panel. I assumed it would take a default metric of 10, but then I get an error, metric can’t be 0.

So I try to put it in other fields, and nothing works.

How can I use the panel to add the MX? What goes in each field?


#2

Are you adding from the DNS panel or via Mail -> MX? If the latter, you don’t add the metric or the trailing dot - just add the hostname you’re pointing the MX record to. I think the metric will then be set to 0.

If the former, make sure FIRST that you’ve disabled the mail service for the domain entirely. I’d avoid doing this anyway, if at all possible.


#3

The mail service is disabled, and no current MX records exist. We’re hosting our own Exchange servers at the company’s site.

Here’s what I’m doing:
Name = mail
Type = MX
Value = IP Address of Mail

There is a corresponding A record for mail…check that - it disappeared…

Anyway, I hit add, and I get the following error:

Invalid metric (format ‘0 my.domain.com.’ where 0 is the metric)


#4

That’s not what you want.

You probably want:

Name: mail
Type: A
Value: IP address of mail server

and then:

Name: [left blank]
Type: MX
Value: 0 mail.example.com.

(where example.com is the domain).

If you want to accept mail for "user@mail.example.com" too, then you can optionally add an MX for mail.example.com as well, though it’s not strictly necessary.