I’m having some trouble with MultiViews for clean URLs. On other hosts I can create a .php file like so:

I can turn on MultiViews and FollowSymLinks to turn the file into a handler for clean URLs, like this:

Nice not only because URLs are clean, but I don’t have to create RewriteRules. Only, this doesn’t work on DreamHost, as far as I can tell. Appending to the basename of the file comes up with a 404 error.

Has anyone come across this before?

I believe the solution is to add this to php.ini:


But you need to compile your own PHP to get that, so the easier solution is probably to use rewrite rules…

I suggested this php.ini fix a while back, but I assume Dreamhost is reluctant to change a setting like that site-wide, in case someone is relying on the current behaviour. (I don’t know if it would break other things.)